Questions tagged [dbachecks]

dbachecks is a Windows PowerShell module created as a framework by and for SQL Server pros who need to validate their environments.

Filter by
Sorted by
Tagged with
0 votes
1 answer
112 views

Oracle Database Tablespace space sizes and percent used in OEM questions.?

I am new to Oracle, and I am not quite understanding the size calculations shown in OEM under tablespaces. I know it should be simple and my well be. I need to monitor the table space but not sure ...
jmichaelwDBA's user avatar
1 vote
0 answers
131 views

dbatools, DbcCheck Does not use Saved credential

Last week I deployed dbccheck on the production environment. I found strange thing and have no idea what the problem is. We have 40 db vm's which are not domain joined. Each of db vm's have same ...
kedar's user avatar
  • 23
-1 votes
1 answer
75 views

How to send dbachecks output to a file on disk?

How do you send the dbachecks output to a file on disk? I tried the following but it resulted with the output on screen and a 0 kb file on disk. Invoke-DbcCheck -Check Database -SqlInstance myserver -...
user2368632's user avatar
  • 1,097
2 votes
1 answer
1k views

DBCC CHECKDB getting terminated abnormally

We have a SQL Server 2014 set up on Always on AG with one primary node and 2 secondary nodes. On the primary node, DBCC CHECKDB for one of the databases is scheduled on SQL agent job. This job was ...
GopiMth's user avatar
  • 31
0 votes
3 answers
931 views

How to perform bulk delete and release free space?

Good Afternoon, We have a database that wasn't been an archive anytime. The database has grown tremendously and we are running short of space. Hence there is a need to do a bulk delete and free space. ...
rushabh138's user avatar
1 vote
0 answers
243 views

Unable to execute dbachecks command

i installed dbachecks module in a server. but when i am trying to execute get-dbccheck, it is throwing the below error Populating RepositorySourceLocation property for module Pester. VERBOSE: Loading ...
Saravana Kumar's user avatar
0 votes
1 answer
3k views

Encrypt connection when using sqlcmd

Trying to connect database with an encrypted connection, tried below sql queries: sqlcmd -N -E -S tcp:SQLSERVER,1234 -U username -P password -d Database -Q "INSERT INTO table1 VALUES(1,2,2) ERROR:...
chris's user avatar
  • 103
1 vote
1 answer
291 views

How to monitor Mongo databases and Cloud servers? [closed]

We have mongo databases installed in AWS and Azure based servers. We need to monitor the Mongo databases and Cloud servers on daily basis. Is there any way to healthcheck the databases and servers ? ...
Mr Surya's user avatar
1 vote
2 answers
306 views

dbatools, DbcCheck LastBackup

Last week I started testing dbccheck on my test system. I found one strange thing, and I have no idea what is the problem, last fullbackup is few hours old, but dbccheck print an error. Following you ...
KW_1970's user avatar
  • 11