As of May 31, 2023, we have updated our Code of Conduct.

Questions tagged [freetds]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer

SSIS Package execution fails when started by user logging in with FreeTDS

I am attempting to let a login kick off an SSIS package via the built-in SSISDB stored procedures instead of doing so through SQL Agent. The login will be connecting through an Airflow DAG on a ...
LowlyDBA - John M's user avatar
1 vote
1 answer

What do these error messages mean?

This is running on an AWS AMI EC2 Linux instance in a PHP script using dblib and PDO to connect to remote Sybase databases (Sybase version The server has freetds with these settings: ...
raphael75's user avatar
  • 244
2 votes
2 answers

MS SQL Server 2000 ODBC driver for Linux

Microsoft has official ODBC drivers for MS SQL Server, for Linux. Great! Nice installation instructions for all the major distros, too. Unfortunately, their ODBC drivers, going back to the oldest ...
Dan Lenski's user avatar
2 votes
1 answer

FreeTDS TSQL connect string

I am unable to connect to a MSSQL 2012 Server using FreeTDS on OSX in the terminal when I pass the -P . Example: V-MBP:etc vashavoc$ tsql -S SERVER_IP -p PORT -U USER -P PASSWORD locale is "en_US....
vashavoc's user avatar
  • 183
4 votes
1 answer

supplementary characters in FreeTDS

I have a C++ application that connects to SQL Server 2008 through FreeTDS unixODBC on an RHEL box. However, i am unable to insert supplementary characters to the database through FreeTDS unixODBC. [...
D3XT3R's user avatar
  • 73
3 votes
0 answers

ORA-28545 (Net8) error when connecting Oracle 12c on Centos 7 to SQL Server 2014

I have installed Oracle 12c on Centos 7 and I wanted to connect SQL Server 2014 using freeTDS. So, I installed the following: FreeTds. unixODBC. Next, I configured ODBC on the Linux server so that, ...
danarj's user avatar
  • 169
0 votes
1 answer

SQL Server to MySQL sync, using Workbench, FreeTDS, and iODBC on 10.9

I've been struggling to get the MySQL Workbench to behave properly to complete the following: With Mavericks (OS X 10.9), connect to a SQL Server and create a migration job to a MySQL server. The ...
CDD's user avatar
  • 143
5 votes
1 answer

Can connect to SQL Server through tsql but not from the bsqldb

After installing FreeTDS I was able to connect to our SQL Server using tsql but not yet through bsqldb. With bsqldb it's trying to connect to the master even though the db was specified to testDB. ...
dhew's user avatar
  • 51
2 votes
1 answer

SQL Server connection failed for domain user from Mac OS machine

I have SQL Server 2008 R2 SP1. I am using connection string to connect to SQL Server. In connection string I am passing the driver path, server name, TCP port number, user name with which I want to ...
Tausif's user avatar
  • 21
6 votes
1 answer

SQL-08S01 error in FreeTDS/Azure when executing stored proc for a few minutes from Linux (but not from Windows)

I get this error on Linux (Ubuntu and CentOS) when executing a stored proc from Perl/DBI/ODBC/FreeTDS to SQL Azure: [unixODBC][FreeTDS][SQL Server]Read from the server failed (SQL-08S01) I don't get ...
Cade Roux's user avatar
  • 6,592
3 votes
1 answer

tds: unable connect to SQL Server using servername specified in freetds.conf file

I am using freetds to connect to SQL Server from ubuntu. First, the SQL Server is running at port 1433 currently. I can telnet it. The following command also works. I can query table data using it, ...
Xiaoyu Di's user avatar
1 vote
1 answer

Running query against SQL Server with FreeTDS's bsqldb returns blank output

Here is the query I ran select CAST(PageGuid as varchar(max)) + ',' + CAST(TenantGuid as varchar(max)) + '/' + CAST(OriginalFileGuid as varchar(max)) from Pages This worked with tsql but when run ...
David's user avatar
  • 203
7 votes
3 answers

Easy path to REST on SQL Server?

At work, one of our primary databases is running on MS SQL Server. I think it's 2008. I'm currently hitting it via UnixODBC and FreeTDS from a Linux host. Unfortunately, the UnixODBC/FreeTDS are not ...
the Tin Man's user avatar
4 votes
1 answer

How to make iSQL/FreeTDS behave like a normal client?

I have a third-party Sybase database, which my users would like to connect to and query from a Linux box, using iSQL. I have installed UnixODBC and FreeTDS. As it is third-party database however, I am ...
Gaius's user avatar
  • 11.2k