Skip to main content

Questions tagged [homebrew]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
29 views

Removing mongoDB from MacOS

I need to delete all mongoDB thing in my mac. i followed the uninstall guide on mongoDB uninstall official guide but on step 2 which is `launchctl unload ~/Library/LaunchAgents/homebrew.mxcl.mongodb-...
antisuri's user avatar
2 votes
2 answers
649 views

What is causing my ERROR 2002 (HY000): Can't connect to local server through socket '/tmp/mysql.sock' (2)?

I'm using brew install mysql/brew install mariadb, and cannot find a way around the following error: ERROR 2002 (HY000): Can't connect to local server through socket '/tmp/mysql.sock' (2) Here are the ...
It's WPTom's user avatar
0 votes
2 answers
560 views

How to install sqlplus in macOS M1 Pro ( silicon chip)

I have been searching in internet for best way to install sqlplus in MacOs apple silicon chip ( arm bases processor). please guide me some easiest method to do that. I saw that many article about ...
user avatar
-1 votes
1 answer
297 views

How do I connect to a PostGres 14 server installed via Homebrew on Mac OS Big Sur?

I installed PostGreSQL 14 via Homebrew. I seem to be able to restart my local server ... $ brew services restart postgresql@14 Stopping `postgresql@14`... (might take a while) ==> Successfully ...
Dave's user avatar
  • 723
0 votes
0 answers
364 views

MySQL and MariaDB on same macOS via brew

How do I install mariadb on my macOS Mojave via homebrew without destroying my MySQL 8 setup ? Error: Cannot install mariadb because conflicting formulae are installed. mysql: because mariadb, ...
anjanesh's user avatar
  • 279
4 votes
1 answer
529 views

Brew Upgrade Mysql: sdi_delete failed: Record Doesn't exist: tablespace_id: 1 Key: 1 4049

I ran the following commands from the cli in MacOS Monterey V 12.4: brew update brew upgrade Upon doing so, MySQL was upgraded from 8.0.30 to 8.0.31. MySQL was running in the background during the ...
Derrick's user avatar
  • 141
1 vote
1 answer
757 views

MySQL Plugin "mysql_old_password" not loaded

In an attempt to fix another issue I had, I ran the commands below (as per https://dev.mysql.com/doc/refman/5.6/en/old-client.html) mysql> UPDATE mysql.user SET plugin = 'mysql_old_password' mysql&...
The Royal Guardian's user avatar
0 votes
1 answer
3k views

mysql on Mac Monterey not working regardless what I do

I am running a Mac on Monterey v 12.4 with an M1 Max. I tried to install mysql on my Mac but I never get it to work regardless what I do. The first thing I tried to do is: $ brew install mysql Then I ...
user avatar
1 vote
1 answer
6k views

Postgres CREATE DATABASE Not Working

I'm on a Mac using Monterey. It's a Mac M1 which had a bit of an issue using homebrew to install postgres when I first started working on this machine. I moved to the GUI postgres.app which just ...
Rich_F's user avatar
  • 131
1 vote
0 answers
194 views

Have I destroyed my postgresql database?

I installed psql using homebrew and I use it for some local data tracking. However, there were some issues with installing ruby using homebrew, so one suggestion was to reinstall it. Which I did, and ...
hargun3045's user avatar
3 votes
0 answers
720 views

How do I find out details about an error showed iby "brew services list"?

I want test my postgres13 service on mac by using "brew services list". I got following: $ brew services list Name Status User Plist postgresql error gerd /Users/gerd/...
Gerd's user avatar
  • 143
3 votes
1 answer
13k views

Server quit without updating PID file when trying to start MySQL server?

So I created my .bash_profile, opened it in a text editor and added: export PATH=$PATH:/usr/local/mysql/bin and then I saved it. Next, I tried running sudo /usr/local/mysql/support-files/mysql.server ...
nickcoding's user avatar
0 votes
1 answer
3k views

postgres: could not find the database system

If I try to run the postgres command, I get: 2020-12-29 00:14:53.213 GMT [34374] LOG: skipping missing configuration file "/usr/local/pgsql/data/postgresql.auto.conf" postgres: could not ...
Troy's user avatar
  • 111