Questions tagged [unixodbc]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
80 views

Can't use ODBC to connect to MariaDB

Linux Mint 20 (Ubuntu 20). MariaDB version: "mariadb Ver 15.1 Distrib 10.7.3-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2" LibreOffice 6.4.7.2. I want to run LibreOffice Base ...
user avatar
0 votes
1 answer
129 views

Connecting to SAP ASE fails

ALL, igor@IgorReinCloud ~ $ cat /etc/unixODBC/odbc.ini [Sybase16] Driver=Sybase Description=Sybase 16 Native Driver Trace=Yes Server=REINCLOUD Database=draft TraceLog=/tmp/sql.log Port=5000 UserID=sa ...
user avatar
  • 207
2 votes
1 answer
176 views

Incompatibility between unixODBC and Firebird ODBC driver

I'm currently developing a application based in Rcode, ODBC and Firebird. For that, first I've installed firebird server and unixODBC (both 64 bits since my machine OS is 64-bits). I tried with 32-...
user avatar
  • 63
0 votes
1 answer
9k views

unixODBC - [IM002][unixODBC][Driver Manager] Data source name not found and no default driver specified

Folks, We installed unixODBC-2.3.7 on Aix 7.1 to connect to Oracle 11g. After setup odbc.ini and odbcinst.ini files and tried to connect with isql, we had the following error: # isql -v ORACLE [...
user avatar
0 votes
1 answer
432 views

BCP via Linux Centos 7, cannot connect to Azure SQL

I installed sqlcmd, bcp and odbc 17 for microsoft. then I connected to Azure SQL with SQLCMD - it worked OK then I tried to import some data with BCP and i got an error I use: bcp schema....
user avatar
5 votes
1 answer
7k views

installed SQL Server on RHEL7 and received - Sqlcmd: Error: Microsoft ODBC Driver 13 for SQL Server : TCP Provider: Error code 0x2AF9

I installed SQL Server on RHEL7 VM msodbcsql-13.1.1.0-1.x86_64 mssql-server-14.0.100.187-1.x86_64 mssql-tools-14.0.2.0-1.x86_64 # ls -al /opt/ total 4 drwxr-xr-x. 5 root root 52 Jan 13 08:31 . ...
user avatar
  • 2,188
0 votes
2 answers
6k views

Connecting to SQL Server from R which is Running on Remote UNIX Machine

We have a UNIX machine which includes R engine on it and installed SQL Server ODBC Driver 11. We need to connect R to SQL Server. SQL Server currently works on another machine, so we tried to connect ...
user avatar
4 votes
1 answer
1k views

supplementary characters in FreeTDS

I have a C++ application that connects to SQL Server 2008 through FreeTDS unixODBC on an RHEL box. However, i am unable to insert supplementary characters to the database through FreeTDS unixODBC. [...
user avatar
  • 73
1 vote
0 answers
474 views

floating point exception in isql with mariadb

I have this problem in my Debian server : $ isql -v asterisk-connector [1] 13397 floating point exception isql -v asterisk-connector I already checked logs / google and got nothing Distributor ...
user avatar
3 votes
0 answers
1k views

ORA-28545 (Net8) error when connecting Oracle 12c on Centos 7 to SQL Server 2014

I have installed Oracle 12c on Centos 7 and I wanted to connect SQL Server 2014 using freeTDS. So, I installed the following: FreeTds. unixODBC. Next, I configured ODBC on the Linux server so that, ...
user avatar
  • 169
0 votes
1 answer
5k views

SQL Server to MySQL sync, using Workbench, FreeTDS, and iODBC on 10.9

I've been struggling to get the MySQL Workbench to behave properly to complete the following: With Mavericks (OS X 10.9), connect to a SQL Server and create a migration job to a MySQL server. The ...
user avatar
  • 143
7 votes
3 answers
15k views

Easy path to REST on SQL Server?

At work, one of our primary databases is running on MS SQL Server. I think it's 2008. I'm currently hitting it via UnixODBC and FreeTDS from a Linux host. Unfortunately, the UnixODBC/FreeTDS are not ...
user avatar
4 votes
1 answer
1k views

How to make iSQL/FreeTDS behave like a normal client?

I have a third-party Sybase database, which my users would like to connect to and query from a Linux box, using iSQL. I have installed UnixODBC and FreeTDS. As it is third-party database however, I am ...
user avatar
  • 11.1k