Questions tagged [upgrade]

Upgrade refers to the replacement of a product with a newer version of the same product. - replace (a software program) with a more recently released, enhanced version. - replace (a hardware device) with one that provides better performance.

Filter by
Sorted by
Tagged with
0
votes
1answer
277 views

Unable to upgrade to postgresql 13

I'm getting the following error: postgres@:~/>cat loadable_libraries.txt could not load library "$libdir/plpython2": ERROR: could not access file "$libdir/plpython2": No such ...
0
votes
1answer
112 views

mysql hardware refresh + version upgrade

currently I am running MySQL 5.0.80 on windows server 2003 (x64), 64gb memory, I have a master and 2 slaves. It's a large 400 gb Database. I am setting up all new hardware (SAN + dedicated MySQL ...
1
vote
1answer
134 views

How to upgrade a MySQL database using numbered scripts based on a version field

I have a database that contains a version table with one value stored in it which is the database version number. I would like to be able to update the database version automatically using numbered ...
0
votes
1answer
20 views

CockroachDB upgrade not finalized

I am running a three-node CockroachDB docker cluster (Debian OS) and I recently upgraded the cluster from version v21.1 to version v21.2 following the procedure outlined in the documentation using the ...
1
vote
1answer
463 views

dockerized postgresql listing no clusters

I'm upgrading an existing dockerized postgres:9.6 to 10. There are plenty of good Q/As on DBA and SO that go the path of pg_upgradecluster, but it is not working for me. When I start a vanilla pg:10 ...
0
votes
0answers
11 views

fix InnoDB: corrupted TRX_NO after upgrading to 10.3.31

After upgrading mariadb from 10.3.25 to 10.3.31 it fails to start like described in this bug report I temporary fixed it by downgrading mariadb to 10.3.25 again like I described here. To fix this ...
0
votes
1answer
18 views

After a database upgrade from MariaDB 10.1 to 10.6 new ODBC connections are returning wrong values

In somewhat related questions I notice the discusions of Data Engines. I have some tables set to MyISAM and some set to InnoDB but not sure if this could be causing the problem. I used to connect to ...
2
votes
1answer
355 views

Non-CDB database vs Single tenant CDB

I am looking at the prospect of upgrading from oracle 11G to 12C, and I am looking at the cdb vs non-cdb models, and I am having a hard time seeing the benefit of using CDB, without multitenant ...
0
votes
1answer
29 views

Postgres Upgrading Errors due to table not existing

I am trying to do an upgrade from Postgres 9.6 to 12, I have done this in the past but in this instance I am having difficulty. When running the pg_upgrade command followed by the parameters: /usr/...
-1
votes
1answer
181 views

Any impact of upgrade db2 from V10.5 to V11.5?

Good day, Due to the DB2 v10.5 will end of support on next year April. I would like to change my application database version to v11.5. Before apply this to production, I do it in my local VM first....
0
votes
1answer
113 views

how to upgrade postgresql 9.0.4 to latest with minimum downtime

I have master-slave-slave setup for postgresql 9.0.4 in our production setup. We need to upgrade it to latest (11.X), so my question is what would be the procedure to do so with as little downtime as ...
0
votes
1answer
5k views

“ORA-03146: invalid buffer length for TTC field” after upgrade from Oracle 12 to 19c

We are experiencing problems with updating a table record BLOB column. We get the "ORA-03146: invalid buffer length for TTC field" error. We basically are saving e.g. PDF attachments to the ...
0
votes
0answers
22 views

pg_ctl error when using pg_upgrade

We are attempting to upgrade Postgres 10.10 to 12.4 using pg_upgrade on a Windows 2016 Server machine using the command "C:/Program Files/PostgreSQL/12/bin/pg_upgrade.exe” --old-datadir "C:/...
0
votes
1answer
100 views

MySQL upgrade via mysqldump

We want to upgrade to MySQL 8.0 from MySQL 5.6 but upgrade manual seems to cumbersome and risky to follow doing an in-place upgrade so we have decided to do it via MySQL Workbench export (mysqldump) ...
1
vote
1answer
613 views

Is Oracle 12.2 backward compatible with Oracle 12.1

Current Oracle DB I am using is 'Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit' and we have a use case for using 'Oracle 12.2.X.X.0'. We want to use the elongated object name ...
0
votes
1answer
41 views

List of deprecated features for PostgreSQL 8 to 13

I'm going to upgrade several PostgreSQL 8 databases to version 13. The people I work for come from SQL Server. I've been looking for a tool similar to "DMA", specifically the part that lists ...
2
votes
1answer
92 views

Postgres major version upgrade using replication server

I am planning to upgrade my database from Postgres 10 to Posgres 14. To reduce the downtime, I plan to use the replication for the same. Plan (in short) is to: Dump the data using pg_dumpall Kill the ...
0
votes
1answer
1k views

MySQL upgrade from 5.6 to 8.0

When trying to start MySQL 8.0 it complained about partially upgraded DD. Furthermore, it complained about not being to open a table S/AD.ibd which no longer exists there because we moved it to S/AD....
0
votes
1answer
95 views

Transactional replication upgrade from SQL Server 2017

We would like to inplace upgrade of transactional replication topology from SQL Server 2017 to SQL2019 with minimal downtime. The following is the setup. All the all current instances are on SQL ...
0
votes
1answer
68 views

Upgrading Postgres major version using logical replication

We have considered some options to upgrade our Postgres servers from the current (10) version to the latest (14). We decided no to do on the primary - since we need to do with the link option (so in ...
6
votes
3answers
5k views

Eliminating OIDs while upgrading PostgreSQL from 9.4 to 12

I'm currently running PostgreSQL 9.4 in my production environment, but we're in the process of doing an OS upgrade on the server so I thought it might be time to upgrade our PostgreSQL version to the ...
0
votes
0answers
24 views

MariaDB upgrade fails on replication slaves

I am having problems when a MariaDB replication slave wants to upgrade its tables after a server was patched. This happens consistently with any sort of OS patching. The system has several slave ...
0
votes
1answer
3k views

pg_upgrade issue from postgres 9.3 to 9.6

I am trying to use pg_upgrade to upgrade postgres server from 9.3 to 9.6. I have both binaries on the windows server R8. Here are the 2 pg_hba.conf : > 9.3 : # TYPE DATABASE USER ...
5
votes
1answer
2k views

Replication stops with GTID_NEXT error after creation/drop of memory table in mysql5.6

We have recently upgraded to mysql5.6.25 from mysql5.5.x/mysql5.1.x on our mysql-cluster. Below is a brief snapshot of our architecture. Since we have upgraded and enabled gtid-mode we have been ...
0
votes
2answers
556 views

Side By Side Upgrade and Migration from 2008 to 2016

Side By Side Upgrade and Migration from 2008 to 2016 Old Server Name Test1 New Server Name Test1 Default Instance Test 1 My question is when the new server be named as the old one 'Test1" and it ...
0
votes
1answer
3k views

How to Recover My database From Old WampServer?

Previously I am using wampserver2 with "mysql5.6.17" version.I have many database in that version. I uninstall the wampserver and install new latest version wampserver3.1.0_x64. Before uninstalling ...
0
votes
1answer
42 views

Incompatible function reference when upgrading to Postgres 13

I want to upgrade a Postgres 9.6 database on CloudSQL (GCP) up to version 13. As SQL export/import is the only supported upgrade path, I've exported the PG9.6 database and attempted to import it into ...
0
votes
1answer
2k views

Mysql_upgrade fails, table is corrupted

I have a mariaDB with a table that is corrupted. It's useless data to me, so I've tried to drop the schema but it won't drop. Instead, it gives me this error when trying to drop it: "Error Code: 1805....
2
votes
1answer
4k views

Read concern level of majority error while upgrading Sharded Cluster from 3.2 to 3.4

I have upgraded MongodDB sharded cluster having two replica sets from 3.2 to 3.4. Current storage engine is MMAPv1. After successfully upgrading all the secondary, primary, config server and mongos to ...
1
vote
2answers
413 views

MySQL Upgrade on Windows

I am having MySQL 5.1 installed on windows box. Now I would like to upgrade to latest MySQL 5.6 version. I am planning to install MySQL 5.6 in the same server with same port 3306. After installation, ...
1
vote
1answer
238 views

Percona-Server: slow TokuDB queries after upgrading from 5.6 to 5.7. ANALYZE TABLE doesn't resolve the problem

After upgrading from Percona-TokuDB 5.6.29-76.2 to 5.7.19-17 we see some very slow queries on some tables without primary keys, but multiple non-unique indexes. The box we migrated to is pretty well ...
0
votes
1answer
593 views

Drop tables but space not claimed in postgres 12

I have upgraded Postgresql 9.5 to Postgresql 12.4 a few days back using pg_upgrade utility with link (-k) option. So basically I am having two data directories i.e. One is old data directory (v9.5) ...
1
vote
1answer
954 views

Is there a way to automatically upgrade DBeaver?

I am trying to update DBeaver Community Edition 7.0.3 to (currently) newest 7.1.0 edition on Fedora 30. When I start DBeaver a "Version Update" window pops up with buttons as options to Upgrade and ...
1
vote
2answers
123 views

Upgrade BI server to 2014 and stay on 2008r2 with the database engine server

We would be happy to upgrade our SQL Server environments to 2014, but we have a tight budget for next year. Our BI server (SQL Server 2008 Standard Edition, that is used only for BI purposes) is ...
1
vote
1answer
43 views

Why would anyone ever want to dump/restore if you can just use pg_upgrade?

pg_upgrade (formerly called pg_migrator) allows data stored in PostgreSQL data files to be upgraded to a later PostgreSQL major version without the data dump/reload typically required for major ...
0
votes
4answers
1k views

Wrong InnoDB table status (Size/Rows) after updating from MySQL 5.7 to 8

I've upgraded from Mysql 5.7 to 8 on Ubuntu 18.04 Made it by guide, very accurate, on a new empty server, checked all error/warning logs and fixed it. Everything works just fine with it. I have 2 ...
0
votes
1answer
788 views

Mongo E11000 duplicate key error collection after mongo 3.4 to 3.6 upgrade

I have a Mongo replica set on Ubuntu with three members configured for my information system and am having issues when I try to upgrade MongoDB from version 3.4 to 3.6 After setting the "...
0
votes
0answers
196 views

Upgrade Postgres database from 10 to 13 running in Docker

I have a Postgres database running in a docker container (https://hub.docker.com/_/postgres). The docker image is postgres:10.0 and I would like to upgrade to postgres:13.3. If I just change the image ...
0
votes
0answers
431 views

ERROR 1932 (42S02): Table '....' doesn't exist in engine after upgrade mariadb

I need use JSON_OBJECT builtin mariadb function, but mariadb version in server 10.0.xx, then we upgrade to 10.4.20-MariaDB. Then now mariadb version is 10.4.20-MariaDB But some table can't be accessed ...
0
votes
0answers
81 views

Postgres major upgrade with repmgr

I have a three node cluster pg_version 10, i'm trying to upgrade it to pg_version 11. Also, that cluster is managed by repmgr 10, which should also be upgraded to version 11. I have followed after ...
1
vote
2answers
124 views

Why does the SQL Server build number sequence not correlate with the release date sequence?

I'm looking at the Microsoft SQL Server 2016 Builds (see that section heading). The list of builds is given in build number order. That is, at the top of the list is the "highest" build ...
0
votes
0answers
22 views

Upgrade MySQL Version, need I also upgrade the database as well?

I am running MySQL 5.6.51. And I notice that there is MySQL 8.x. Based on https://severalnines.com/database-blog/tips-for-upgrading-mysql-5-7-to-mysql-8, I need to first upgrade from 5.6.x to 5.7.x, ...
2
votes
2answers
238 views

SQL Server 2016 database backup fails to restore on SQL Server 2019

We were trying to restore the database from SQL Server 2016 Developer Edition to SQL Server 2019 Developer Edition and it was failing with an exception. Details about this DB: It has in-memory ...
-2
votes
2answers
35 views

MySQL Upgrade Procedure in a production environment [closed]

Am new to the role and employers have asked me to come up with a plan to upgrade the MySQL 5.6 on the production server to 5.7. It has partitions and MASTER-MASTER replication setup and has around ...
-2
votes
1answer
122 views

SQL Server 2016 : upgrade from SP2-GDR to CU15

I tried to upgrade one of my SQL Server from 2016 SP2-GDR to 2016 SP2 CU15, but I got nothing can be upgraded warning. Is this normal? The error says: There are no SQL Server instances or shared ...
0
votes
1answer
909 views

How do I correct InnoDB Multiple files found for the same tablespace ID?

Some time ago after an update of Ubuntu 20.10, I discovered that MySQL was not running. When I tried to restart it, the error message suggested that it had started, failed and stopped. A check of the ...
0
votes
2answers
59 views

Remove Query Tuning Assistant (msqta) schema and tables

When running the Query Tuning Assistant (using the New Database Upgrade Session) on SQL Server 2017 I have a new schema msqta created in the corresponding database as supposed, along with six tables ...
1
vote
1answer
1k views

Perform Postgres Upgrade from 9.6 to 13 with minimal downtime

I am looking to upgrade our Postgres 9.6 server to Postgres 13. I have looked into the following options: pg_upgrade, if I was doing this without the --link option, this would take considerable time ...
1
vote
1answer
1k views

All instances upgrade from Command Prompt

I want to create a cmd script to upgrade sql servers in the organization(mostly 2014) to 2016. I've read Microsoft documentation Install SQL Server 2016 from the Command Prompt regarding this issue. ...
1
vote
1answer
565 views

Cannot resolve the collation conflict between "Latin1_General_CI_AS" and "SQL_Latin1_General_CP1_CI_AS" in the equal to operation

Need urgent help on this. We have applied latest sql patches on one of the server (SQL 2014, SP3, CU4) and somehow we were not able to start the SQL due to following error. Cannot resolve the ...

1
2 3 4 5
9