Questions tagged [upgrade]

Upgrade refers to the replacement of a product with a newer version of the same product. - replace (a software program) with a more recently released, enhanced version. - replace (a hardware device) with one that provides better performance.

Filter by
Sorted by
Tagged with
1
vote
1answer
16 views

In place upgrade from Express 2005 SP 4 to Express 2014, does database size limitation follow?

We are currently attempting get around a file size limitation issue with our database. The database file size hovers around the 4GB mark (the database size limit is 4GB in SQL Express 2005). We always ...
-2
votes
0answers
37 views

Use of Database Upgrade Assistant to upgrade-oracle-from-12-to-19c [closed]

Our team is trying to upgrade Oracle 12 to 19C. Did anyone tried Database Upgrade Assistant to upgrade-oracle-from-12-to-19c? I found below link/steps for upgrade from research? Did anyone tried? ...
0
votes
0answers
11 views

AWS Aurora Postgres 9.6 major version upgrade via slony?

The official documentation states that the major in-place version upgrades are not possible. Note Aurora PostgreSQL does not currently support in-place major version upgrades. To migrate a ...
-2
votes
0answers
21 views

Upgrade Oracle from 12 to 19C [closed]

Our team is trying to upgrade Oracle 12 to 19C. Did anyone tried below link/steps for successful upgrade? Thanks in advance!!!
0
votes
2answers
40 views

SQL Server 2016 upgrade to SQL Server 2017 [closed]

Have you upgraded from SQL Server 2016 to 2017 before? Can we use a SQL Server 2016 user database backup and restore to SQL Server 2017? Is in place upgrade approach better than do a backup/restore? ...
0
votes
0answers
9 views

Upgrading MySQL takes forever

I am upgrading a MySQL database from 5.6 to 5.7; it contains a few tables that are obscenely big, >500m rows in one case. I started the mysql_upgrade yesterday, and it has been chewing its way through ...
0
votes
0answers
7 views

Windows 2016 server with .NET version 3.5 having issue with connecting to mongo 3.0 replicaSet

We have a mongo server version 3.0 and driver version 1.11.0.92 and windows server 2016. I see other posts related to this but our code works well in Windows 2008 server with mongo version 3.0 and ...
0
votes
1answer
11 views

Upgrading Microsoft SQL 2014 and Always On AG Configurations

I'm getting ready to perform an upgrade from SQL 2014 to 2017 on two servers that are configured for Always On. The concern on the upgrade is how to break Always On to stop replication and to keep any ...
0
votes
0answers
28 views

SQL Server 2017 Machine Learning repair fails

CU17 update failed on an Enterprise 2017 box, both R and Python (we use both). I removed them both. Trying to Add Feature, and R still fails - Python is good. Removed R again, after stopping ...
2
votes
0answers
22 views

SQL Server update from GDR to CU-17 [duplicate]

I'm using SQL SERVER 2017 GDR version 14.0.2002.14. I want to upgrade to the latest possible version of SQL Server 2017. My question is can I download CU-17 and directly run the latest cumulative ...
1
vote
1answer
203 views

Upgrading SQL Server 2019 from CTP to RTM version

A few days ago Microsoft announced RTM version of SQL Server 2019 finally and we are willing to install and use it on our business intelligence server. We are already using Microsoft SQL Server 2019 ...
0
votes
1answer
29 views

How to ensure database is cataloged

I am planing to upgrade my database. I am referring to this website: https://www.ibm.com/support/knowledgecenter/SSEPGG_11.5.0/com.ibm.db2.luw.qb.upgrade.doc/doc/t0007193.html On the Before you begin ...
0
votes
1answer
30 views

Upgrading Mongodb from 3.2.6 to 4.2. Which is the better way to do it?

What is the best way to upgrade MongoDB? Say I have 3.2.6 and I want to upgrade to 4.2 Can I just use mongodump and mongorestore? Or are there any intricacies to it?
1
vote
1answer
28 views

Any impact of upgrade db2 from V10.5 to V11.5?

Good day, Due to the DB2 v10.5 will end of support on next year April. I would like to change my application database version to v11.5. Before apply this to production, I do it in my local VM first....
0
votes
1answer
27 views

Mariadb query time extremely increased after upgrade from 10.2 to 10.4

After upgrading from Mariadb 10.2 to 10.4 extremely increased query time. On 10.2 query time is 0.5s. On 10.4 query time is 14s. Also query plan has changed too. 10.2: -------------------------...
0
votes
1answer
33 views

Strategy for making Postgres support multiple versions of client code

I'm about to embark on an overhaul of our code for pushing to Postgres, and want to solicit some feedback before going on. The setup here is that we've got a lot of software deployed with a non-...
0
votes
1answer
29 views

how to upgrade postgresql 9.0.4 to latest with minimum downtime

I have master-slave-slave setup for postgresql 9.0.4 in our production setup. We need to upgrade it to latest (11.X), so my question is what would be the procedure to do so with as little downtime as ...
0
votes
1answer
22 views

Mongo DB Upgrade 3.0 to 3.2 Verification of Upgrade

We have a few environments with MongoDB 3.0, these are standalone servers. These servers are already using WiredTiger Storage engine. I am trying to upgrade them to 4.2. As per the upgrade ...
0
votes
1answer
60 views

Is Oracle 12.2 backward compatible with Oracle 12.1

Current Oracle DB I am using is 'Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit' and we have a use case for using 'Oracle 12.2.X.X.0'. We want to use the elongated object name ...
0
votes
1answer
221 views

Can I update my Microsoft Enterprise SQL Server? [closed]

I just have a quick question about SQL Server and the various tools that come with it. I updated my SQL Server Management Studio to the latest version because I wanted to use the STRING_AGG function,...
0
votes
1answer
80 views

CU8 for 2016SP2 error

When upgrading to CU8 on 2016SP2, I get the following error Final result: The patch installer has failed to update the shared features. To determine the reason for failure, review the log files. ...
0
votes
3answers
70 views

In-place upgrade vs. new install

My search for this question yielded some similar questions, but none that I could see exactly like this. Question: In your experience, when doing a SQL Server upgrade, say from 2008 to 2017, or from ...
1
vote
1answer
67 views

Upgrade from MariaDB 10.3 to MariaDB 10.4 with Galera Cluster - mysql.global_priv table

I have 3-node MariaDB 10.3 Galera Cluster (Ubuntu 14.04) and I want to upgrade it to MariaDB 10.4 Galera Cluster (Ubuntu 18.04). According to https://mariadb.com/kb/en/library/upgrading-from-mariadb-...
-4
votes
1answer
145 views

Is SQL Server 2016 already in a good shape to be used? [closed]

So it's time to upgrade out servers. I'm new in this company and we have SQL Servers from 2008 to 2014. I really don't see a problem upgrading all of them to 2014 because it's really wel documented ...
3
votes
1answer
96 views

SQL Server 2008 R2 Edition Upgrade Process

I have several SQL Server 2008 R2 Standard Edition instances that we need to upgrade to SQL Server 2008 R2 Enterprise Edition. If I have valid SQL Server 2017 Enterprise Edition (with SA) PIDs, do I ...
0
votes
1answer
373 views

Mysql_upgrade fails, table is corrupted

I have a mariaDB with a table that is corrupted. It's useless data to me, so I've tried to drop the schema but it won't drop. Instead, it gives me this error when trying to drop it: "Error Code: 1805....
0
votes
1answer
37 views

upgrade MSDB only?

good morning. we currently are running on SQL server 2008 r2 and going to Sql server 2016. we are told we cannot do an in place upgrade and will have to restore all SSIS and jobs manually (script, ...
0
votes
0answers
13 views

Migrate data from database on MarkLogic 7 to database on MarkLogic 9

I need to copy data from a MarkLogic 7 database to MarkLogic 9 database on another system. I tried backup and restore option provided by the MarkLogic Admin console. The original database in MarkLogic ...
0
votes
0answers
28 views

SQL Server upgrade advisor reserved keyword warning - Can't find keyword!

I am running SQL Server 2008 Upgrade Advisor tool on a SQL Server 2000 DB, and the final report shows an error: Database Server,"PreUpgrade", "After upgrade, new reserved keywords cannot be used ...
1
vote
1answer
26 views

Azure SQL Database patch and update doubts

It is known that Microsoft automates the patch and update of Azure SQL Database. But, some times applications must be tested before being applied any type of patch or update, because there's a ...
0
votes
0answers
20 views

After upgrading from PG 9.3 to 10 indices became corrupted

So recently I was upgrading the database in production from Postgres 9.3 to 10. In addition to upgrade, we wanted to move the database to another machine. I know, doing it "in place" would be easier ...
1
vote
1answer
517 views

AWS RDS (PostgreSQL) - Master user lost all privileges after upgrading from v9.6 to v10.6-R1

I just upgraded my AWS RDS DB instance from Postgresql v9.6 to v10.6-R1. I did this manually using the "Modify" tab in the Databases section under the Dashboard. Immediately afterwards, as the master ...
0
votes
1answer
170 views

Wrong InnoDB table status (Size/Rows) after updating from MySQL 5.7 to 8

I've upgraded from Mysql 5.7 to 8 on Ubuntu 18.04 Made it by guide, very accurate, on a new empty server, checked all error/warning logs and fixed it. Everything works just fine with it. I have 2 ...
0
votes
1answer
178 views

Upgrading PostgreSQL 9.3 to 9.5

I want to upgrade version 9.3 to 9.5 but after some steps I find that I upgraded to version 10, but I'm looking to go from 9.3 to 9.5. When I type the pg_lsclusters command I find myself with three: ...
0
votes
3answers
36 views

Debian Wheezy to Jessie — MySQL Dead Slow

We just upgraded the Debian Wheezy(7) to Jessie(8). All upgrades went smooth except MySQL which I think is causing some or exhaustive slowness specially in the MySQL's information Schema. the more ...
5
votes
1answer
744 views

Can we download SSRS 2017 to use with SQL Server 2016?

We are using our organization's SQL Server 2014 SP3 servers. (They also have 2016 SQL Servers, but we elected to skip 2016 and just move to the next SQL servers when they get installed.) We have a ...
1
vote
1answer
178 views

Non-CDB database vs Single tenant CDB

I am looking at the prospect of upgrading from oracle 11G to 12C, and I am looking at the cdb vs non-cdb models, and I am having a hard time seeing the benefit of using CDB, without multitenant ...
-1
votes
1answer
224 views

MySQL 5.7 to MariaDB 10.3.13 configuration overwritten - correct way

I have earlier MySQL 5.7 over Ubuntu 16.04 with following configuration in /etc/mysql/my.cnf. [mysqld] innodb_buffer_pool_size = 1228M innodb_log_file_size = 512M innodb_log_buffer_size = 16M ...
0
votes
1answer
132 views

Changing compatibility level from 2008 to 2016

I have a database with hundreds of stored procedure, views, triggers, function, ... The database Compatibility Level is 2008 (100) and we would like to move it to 2016 (130). The SQL Server version ...
0
votes
1answer
99 views

Restore job run successfully without error but actually not applied during log ship from older version to newer one

Our requirement is for SQL Server 2008 R2 databases to be upgraded/migrated to SQL Server 2016. We want to configure log shipping between SQL Server 2008 R2 (source) and SQL Server 2016 (target). We ...
0
votes
3answers
225 views

Deprecated raiserror detection

I want to upgrade SQL server from 2008 to 2014 versiyon. I checked all of the deprecated features including raiserror syntax. But I have many stored procedures to check. Some of them use new syntax, ...
0
votes
0answers
137 views

postgresql 11 & windows server 2008

I plan to upgrade a PostgreSQL/PostGIS server from 9.6 to 11. The server is running on windows server 2008 R2 64. According to the doc, PostgreSQL 11 and Windows Server 2008 has not be tested. So ...
0
votes
1answer
29 views

Upgrade/Transition Path from MySQL Community 5.6.31 to Enterprise

Full disclosure. I have never upgraded a database. I have a MySQL Community that is not the latest @5.6.31 ( latest is 8 ?) to the paid, Enterprise version. We will ask Tech Support once purchase of ...
1
vote
0answers
442 views

mysql 8 is failure to start after upgrade from 5.7

I've upgraded one of the slave server from mysql 5.6 to 5.7 and now 5.7 to 8. But after up-gradation steps done when i use systemctl start mysqld.service or systemctl restart mysqld facing error and ...
0
votes
3answers
2k views

Downgrading PostgreSQL 10 to 9.4

Are there any particular precautions I should take when downgrading PG 10 to 9.4? I have a database on Heroku (PG 9.4) which I'm going to upgrade to PG 10.6. In case something goes wrong, I want to ...
1
vote
0answers
31 views

SQL Server upgrade re-initializes subscriptions

I recently, in a test environment, upgraded my SQL Server Distributor from 2012 to 2017. The upgrade went off without a hitch but I noticed that after the upgrade was completed all of my subscriptions ...
1
vote
1answer
115 views

Could anyone please help me understand MSSQL Compatibility Level?

I have a task to upgrade a database from SQL Server 2005 to SQL Server 2012. So I took backup of the old database and simply restored it onto SQL Server 2012 (SP3). Executed query on New database: ...
0
votes
1answer
146 views

Upgrade MySQL Master Slave Replication Cluster from 5.7.22 to 5.7.24

I have a two node MySQL cluster with Master Slave replication. The MySQL version is 5.7.22 and the OS is CentOS. I need to upgrade the MySQL version to 5.7.24 due to some security reasons. However, ...
3
votes
1answer
356 views

mysql_upgrade check if it's neccessary to run it

How can I determine, do I need to run 'mysql_upgrade` command on database? Percona-server-5.6.41 is installed and running now for a several monthes. Before it mysql-5.6 was installed. In-place ...
3
votes
2answers
2k views

Upgrading SQL Server 2005 to 2016

I have a requirement to get rid of our old servers, however one of them includes a database server that is currently using SQL Server 2005. We have a new server running with 2016 so I wanted to know ...