Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [wsrep]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
8k views

Should I increase my key_buffer_size?

I have 4 node and database has InnoDB tables. my key_buffer_size is 128M. Should i increase it in my system? My innodb_buffer_pool_size is 75G and innodb_log_buffer_size = 256M. Mem: 96688 ...
Melih's user avatar
  • 284
1 vote
1 answer
2k views

MariaDB Galera Cluster galera.cache file getting bigger than specified gcache.size

We have a 3 node Galera Cluster running on Kubernetes, behind 2 HAProxy PODs configured so, all queries are executed on the first POD/node of the cluster if available, and the other 2 nodes, provide ...
Alex Núñez's user avatar
1 vote
1 answer
1k views

WSREP: Writeset deserialization failed: Unsupported RecordSet version: 2: 71 (Protocol error)

We are running a Mariadb galera cluster with 3 data nodes. Recently one of them crashed and I had to do a SST (State Snapshot Transfer). Nothing I haven't done or seen before. However, after the SST ...
Thomas Wiersema's user avatar
1 vote
0 answers
422 views

Why setting up new galera cluster with mariabackup as sst starts but all other nodes failed with same error?

I did a fresh reinstallation of mariadb-server on all the nodes (I removed using sudo apt purge mariadb-*) I started the first node using sudo galera_new_cluster it went fine and is still running. but ...
Ciasto piekarz's user avatar
1 vote
1 answer
1k views

Innodb not started?

I installed MariaDB_Galera_server10.0 , but when i check the error log i see this: 170118 14:49:09 [Note] InnoDB: 128 rollback segment(s) are active. 170118 14:49:09 [Note] InnoDB: Waiting for purge ...
Yaser Jawi's user avatar
1 vote
0 answers
399 views

Galera log has WSREP: failed to initialize io-cache

I'm having trouble tracking down the cause of an error message that is appearing in my logs every 15 minutes or so. The cause of the error happened whilst performance testing a 3 node Galera Cluster (...
Dan's user avatar
  • 111
0 votes
1 answer
147 views

MariaDB Galera Cluster (10.6.12) and Laravel WSREP issue

I'm administrating a galera cluster with 3 nodes, serving a Laravel application and HAProxy is the gateway to the cluster. We had an interesting issue, and I'm unable to figure out why was there an ...
Imre Bertalan's user avatar
0 votes
2 answers
279 views

How to Prevent the Connections for MariaDB Galera-Cluster When There is Only One Active Node?

I was using "rsync" as the wsrep_sst_method in my galera.cnf files on 3-Node Galera Cluster. When it was so, the system served when there was at least 2 active node. So when any two node ...
TarabydaVllasıCafcaflıAtArabsı's user avatar
0 votes
1 answer
207 views

Mariadb 10.1 / Galera - bootstrap node always doesn't lose quorum

I'm using mariadb10.1.37, wsrep_provider_version 25.3.24(r3825). On my dev cluster (2node+1arbitrator) I found the following behaviour: node1: bootstrap new cluster (using galera_new_cluster, with pc....
Mark S's user avatar
  • 122
0 votes
2 answers
2k views

wsrep_sst_xtrabackup socat starts and stops right away

What I have done: I have restarted mysql on the JOINERNODE to apply some database settings including increasing the back_log and query_cache_size settings. What I am seeing: When I start mysql on the ...
Som3guy's user avatar
  • 75