Questions tagged [wsrep]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
20 views

1 Galera node freezes, rejoin is ok but not working

We have a 5-node Galera cluster in a high-load application. One of the nodes freezes in production. Still the cluster-size=5 and Galera/WSREP writes to this node, but the node is not working. Then we ...
0
votes
0answers
46 views

MariaDB Galera: the node, that needs to be joined to others, starts as “wsrep-new-cluster”

We have 4 node Galera Cluster (10.1.14-MariaDB, wsrep_sst_method=xtrabackup-v2). The 1st node successfully started with "/usr/bin/galera_new_cluster" command. The 2-nd and the 3-rd nodes are ...
0
votes
1answer
72 views

Mariadb 10.1 / Galera - bootstrap node always doesn't lose quorum

I'm using mariadb10.1.37, wsrep_provider_version 25.3.24(r3825). On my dev cluster (2node+1arbitrator) I found the following behaviour: node1: bootstrap new cluster (using galera_new_cluster, with pc....
1
vote
1answer
423 views

WSREP: Writeset deserialization failed: Unsupported RecordSet version: 2: 71 (Protocol error)

We are running a Mariadb galera cluster with 3 data nodes. Recently one of them crashed and I had to do a SST (State Snapshot Transfer). Nothing I haven't done or seen before. However, after the SST ...
0
votes
1answer
741 views

Innodb not started?

I installed MariaDB_Galera_server10.0 , but when i check the error log i see this: 170118 14:49:09 [Note] InnoDB: 128 rollback segment(s) are active. 170118 14:49:09 [Note] InnoDB: Waiting for purge ...
0
votes
1answer
4k views

Should I increase my key_buffer_size?

I have 4 node and database has InnoDB tables. my key_buffer_size is 128M. Should i increase it in my system? My innodb_buffer_pool_size is 75G and innodb_log_buffer_size = 256M. Mem: 96688 ...
0
votes
2answers
916 views

wsrep_sst_xtrabackup socat starts and stops right away

What I have done: I have restarted mysql on the JOINERNODE to apply some database settings including increasing the back_log and query_cache_size settings. What I am seeing: When I start mysql on the ...
1
vote
0answers
222 views

Galera log has WSREP: failed to initialize io-cache

I'm having trouble tracking down the cause of an error message that is appearing in my logs every 15 minutes or so. The cause of the error happened whilst performance testing a 3 node Galera Cluster (...