A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.
4 of 9 added picture

How to set connection timeout for pgAdmin 4 (postgres 9.6)

My PGADMIN V4 version 1.3 Python: 2.7.12 (v2.7.12:d33e0cf91556, Jun 27 2016, 15:19:22) [MSC v.150 Flask: 0.11.1

Pops up the following error every 10 minteus or so:

enter image description here

I read this article many times and still don't see how to do it.

How to set connection timeout value for pgAdmin?

many times, but I still have no idea where one sets the config parameter for connection_timeout. I am connecting from a local host to a local host, so there should be no real problems with keep alives.

I am using PgAdmin 4, PostGreSQL 9.6 on windows 10.

I would like to know the path to:

  • Is this something that has to be set in the server, (e.g. postgresql.conf) and what is the value to set?
  • Or is this something in the client (and where is the client config and what has to be set?)
  • Or is this a bug in PGADMIN
  • Or something else

I see others are also confused:

Is there a timeout option for remote access to PostgreSQL database?