5

Unless MySQL does something strange, using only ASCII characters (i.e. only values 0 - 127) should be the exact same encoding, and hence the exact same size, between ASCII, UTF-8, and many other 8-bit code pages. It's only when you hit code points above 127 (or 0x7F) that UTF-8 starts to require additional space (though technically speaking, standard ASCII ...


4

Why is the accepted answer not working for char(150)? Actually, it does. The problem is your test is bad / invalid. You test column, DataColumn, is using NVARCHAR instead of VARCHAR. The character itself works in both datatypes, but the behavior is different due to how it is being used in each case: In the Find_Invalid_Chars() function (i.e. the "...


3

I have checked out mysql-5.4.46, and searched client/mysqldump.c for "SET character_set_client". It finds [:~/Source/mysql-server/client]↥ 9c3a49ec84b* ± grep 'SET character_set_client' mysqldump.c "/*!50003 SET character_set_client = %s */ %s\n" "/*!50003 SET character_set_client = @saved_cs_client */ %s\n" "SET ...


1

You can remove Default, it is not mandatory. If you look att the grammar it says: | [DEFAULT] CHARACTER Set = Meaning that the table gets this CHARACTER SET. It does not affect other tables. If no CHARACTER Set is declared it is "inherited" from the database definition. This is the same as: CHARACTER Set = DEFAULT I dont know if it is part of the ...


1

The Fiddle is wrong. あ A い I う U え E お O. is 20 characters / 40 bytes when declaring that the client is encoded in utf8 (or utf8mb4). But if you claim that that it is in latin1, it leads to Mojibake or "double-encoding", hence the 30 and 48 that Fiddle shows. あ A い I う U え E お O. --> E38182 41 E38184 49 E38186 55 E38188 45 E3818A 4F 2E For further ...


1

Apparently it seems related to a collation or encoding issue. I'd check database and column collations to ensure both are the same. Server collation SELECT CONVERT (varchar, SERVERPROPERTY('collation')) AS 'Server Collation'; Database collation SELECT name, collation_name FROM sys.databases WHERE name = 'DBName'; Column collation ...


1

The data looks like it is raw XML data without XML Tags, not the translated text. You should probably get that fixed first. In the meantime, you can run the data through XMLTable() to do the translation for you. with data as ( select 'Hallöle slovenĈina Hallöle slovenđina' str from dual ) select a.str, b.str2 from data a, xmltable( '/' ...


1

Just install the DB software then use DBCA to create the database. There you can choose the national characterset. Typically noone uses the installer to create a database. Some others (including me) avoid even DBCA.


1

On export the documentation states: A full export does not, by default, export system schemas that contain Oracle-managed data and metadata. Examples of system schemas that are not exported by default include SYS, ORDSYS, and MDSYS. If you want to be absolutely sure I would switch to a schema-mode import instead. You can still use the full export. That ...


1

I think your problem is that you have exported your dump file with ANSI character set, to take a dump file using UTF8, issue your mysqldump command with option --default-character-set=utf8 and check the results. (AFAIK the same options for mysqldump work for Aurora as well) PS : After your comments, I dug the problem a bit more. The problem comes from ...


Only top voted, non community-wiki answers of a minimum length are eligible