New answers tagged

0 votes

Postgres: how to insert and delete many records and to not run out of space

Autovacuum is probably too slow to keep up with the workload. Set autovacuum_vacuum_cost_delay to 0. The better approach is to use partitioning to get rid of old data efficiently.
Laurenz Albe's user avatar
  • 50.3k
0 votes

Auto vacuum for table ASAP

First of all make sure auto vacuum daemon is enabled or not. The parameters you are currently tweaking is for ANALYSE which is supposed to run after vacuuming. For vacuum control mainly below two ...
Basil Titus's user avatar

Top 50 recent answers are included