1

I am using Sybase JDBC JConnect3 driver to insert large data in a table using Batch Insert feature of JDBC. I am preparing a batch of 100 inserts and executing the batch. But it is throwing below error while executing batch query.

com.sybase.jdbc3.jdbc.SybBatchUpdateException: JZ0BE: BatchUpdateException: Error occurred while executing batch statement: Cannot run this command because Java services are not enabled. A user with System Administrator (SA) role must reconfigure the system to enable Java. at com.sybase.jdbc3.jdbc.ErrorMessage.raiseBatchUpdateException(Unknown Source) at com.sybase.jdbc3.jdbc.SybStatement.handleBatchException(Unknown Source) at com.sybase.jdbc3.jdbc.SybPreparedStatement.executeBatch(Unknown Source) at com.loader.LoadTable.loadDataToOracleFirst(LoadTable.java:367) at com.loader.LoadTable.fetchDataFromSybaseFirst(LoadTable.java:246) at com.loader.LoadTable.main(LoadTable.java:157)

Can anyone tell me excatly what I need to configure to resolve above issue?

migrated from stackoverflow.com Aug 22 '15 at 18:56

This question came from our site for professional and enthusiast programmers.

  • Have you tried the manual? – mustaccio Aug 22 '15 at 17:32
1

Start by trying:

sp_configure "enable java",1

...and restarting the service if necessary. There may be more to it than that, please provide details of your server product, version, and anything else that might be helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy