2

We are currently working on a project to move all of our disparate DBs (MySQL, Oracle, older versions of MS SQL) to SQL Server 2014. So far, pretty much everything has gone smoothly, however, there is one Oracle Database (10g 10.2.0.5), which we're trying to migrate using SSMA that just doesn't show up in the SSMA object explorer.

I have tried connecting to this database using the schema owner, the sys AND the system users and it just never shows up. ALL the other schemas on this instance show up and we can migrate them successfully.

Has anyone come across this issue before? Could anyone suggest possible reasons for this? I - and the SQL Server DBA - am stumped. In the interim, we're migrating subsets of data using smacked-together Perl scripts, but this is obviously not ideal.

0

1 Answer 1

0

Try this

1) Open the project

2) Remove the checkbox on the Schemas branch in the Oracle Metadata Explorer Right-click on the Schemas branch in the Oracle Metadata Explorer and select Refresh from Database. This will automatically put a checkbox on ALL schemas. Let the refresh run. This step can take a good amount of time.

3) Save the project

3
  • Nope. I've tried this. The problem is that the schema never shows up there in the first place, so it doesn't populate the schema in the explorer. Following the steps above still doesn't return that specific schema.
    – Francois
    Sep 18, 2015 at 13:10
  • Ok, you mention there is ONE oracle database. Does that mean you had a few oracle databases that have gone smooth, but this particular one is not?
    – Hector
    Sep 18, 2015 at 13:16
  • 1
    Yes. Like I said, the rest all goes smoothly. It's just this one schema that doesn't show up. Other schemas (Databases) in the SAME Oracle instance all show up.
    – Francois
    Sep 18, 2015 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.