4

We have a merge publication set up on SQL Server 2008R2, with several subscribers. Synchronisation is done through the internet.

Over the last few days, some subscribers are unable to synchronise.

In case it's relevant: This seems to have begun on a day where the disk containing the database's log files had filled up completely, and as a result no subscribers could sync.
I resolved that by shrinking the log file for this database, and of other databases on the same server.

  • There is no error message; synchronisation can go on for several hours (usually it takes up to 30 minutes; an hour in rare cases) until it times out, runs into a connection issue or has its process killed.
  • Reinitialising a subscriber (or initialising a new one), either with the existing snapshot or a new one produces the same result.
  • Other subscribers seem to work as normal. There is no difference between those that work and those that don't that I've been able to pinpoint so far.

The replication monitor on the publisher side simply shows the same few messages repeating endlessly:

  • Retrieving subscription information.
  • Enumerating changes in filtered articles using Subscriber's assigned partition ID.
  • Downloading data changes to the Subscriber
  • Merge completed with no data changes processed.*

*There might be some changes processed, depending on subscriber, but the numbers don't seem to go up.

Messages generated at the subscriber are also repeating:

  • The upload message to be sent to Publisher 'PUBLISHER' is being generated
  • The merge process is using Exchange ID '2EE5080F-2F28-4EA6-A0FA-7DA11F97B945' for this web synchronization session.
  • Uploading data changes to the Publisher
  • No data needed to be merged.
  • Request message generated, now making it ready for upload.
  • Upload request size is 7026 bytes.
  • Uploaded a total of 1 chunks.
  • The request message was sent to 'https://WEB_SYNC_SERVER/replisapi.dll'
  • Downloaded a total of 7 chunks.
  • The response message was received from 'https://WEB_SYNC_SERVER/replisapi.dll' and is being processed.
  • The changes contained in the message downloaded from Publisher 'PUBLISHER' will be applied after having collected and displayed the upload statistics.
  • Downloading data changes to the Subscriber
  • Web synchronization progress: 97% complete.

I upped the log verbosity, and the sync log on the subscriber also shows repeating parts. This is quite big, so I put it in pastebin: http://pastebin.com/GV2N0Lys
(This shows only one instance of the repeating part)

I've been trying to find similar reports for a day and I'm unable to find anything relevant.

Is there anything I'm missing?

  • Did you get this resolved? What did you do? – Max Vernon Mar 12 '18 at 13:38
  • @MaxVernon Someone suggested I update some relevant rows (with their current values) to try and force some data to be transferred. It still was stuck for a bit but worked relatively soon after. I don't know if updating the rows helped for sure. It might have just been a matter of waiting long enough. – George T Apr 8 '18 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.