0

I am working with Oracle 11g XE on a Win7 laptop. I have had this up and running without issue for more nearly two years. Went about a month without connecting, and the next time I tried to I got “ORA-12546: TNS:permission denied”.

Since I first ran into this about a week ago I have:

  • Tried connecting with multiple clients (SQLPlus, PLSQL Developer, DB Forge Studio) all of which report the same error.
  • Tried connecting to other instances with the above clients, all seem to be working fine.
  • Tried connecting using the full connection descriptor instead of the XE alias.
  • Completely removed all oracle clients and installations from my laptop, and reinstalled them. Including cleaning out residual registry entries, as noted here https://superuser.com/questions/256762/how-do-i-completely-remove-oracle-11g.

As far as I can tell, everything seems to have reinstalled correctly in terms of files being where they belong and services running, but I am still getting the same TNS errors.

What should I be looking for at this point?

0

So I still don't know exactly what caused my issues. But after spending way to much time trying to research it and tweak things, I got it working again. The two items that I believe were most critical to the process were:

Updating/syncing my .ora files. In particular I had some with references to localhost that had to be changed to my full machine name.

Granting my individual user full control on my oracle directory. I found a reference elsewhere that noted that the permissions inherited from a group were not being honored correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.