1

Following the recommendations in log_min_duration_statement setting is ignored I set these two values and then reloaded.

log_min_duration_statement = 2000
log_statement = 'none'

However, I'm still getting lots of sub-second BINDLOG, BEGINLOG and PARSELOG entries in the log file. What am I doing wrong?

  • 1
    If the connections are coming from JDBC for example, I have found that sometimes it takes a while for the connections to all be recycled, and thus pick up the changes to l_m_d_s. – bma Sep 8 '17 at 21:41
  • Since those terms do not occur anywhere in the source code, it is difficult to believe that they get produced by the system unbidden. Please give a verbatim example of the entire message. – jjanes Sep 10 '17 at 21:45
1

Check individual users and / or dbs for settings that override server settings for logging:

smarlowe=# alter user smarlowe set log_statement='all';
ALTER ROLE
smarlowe=# alter database smarlowe set log_statement='all';
ALTER DATABASE
smarlowe=# \drds
                   List of settings
   Role   | Database |            Settings
----------+----------+---------------------------------
 smarlowe |          | log_statement=all
          | smarlowe | auto_explain.log_min_duration=1+
          |          | log_statement=all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.