1

postgres 8.4.20

With these settings, the daemon starts :

postgresql.conf

shared_preload_libraries = 'auto_explain'

With these settings, the daemon doesn't start :

postgresql.conf

shared_preload_libraries = 'auto_explain'

auto_explain.log_min_duration = 1000

It is a server with a legacy application, so we cannot upgrade PG. I cannot find documentation of this behaviour / bug...

3
  • What message do you get in the log file?
    – jjanes
    Mar 7, 2018 at 13:40
  • It aborts too early. I tried with log_destination = 'stderr' and after log_destination = 'syslog' but no output.
    – Massimo
    Mar 7, 2018 at 14:25
  • Did you set custom_variable_classes = 'auto_explain' in the postgresql.conf file?
    – jjanes
    Mar 8, 2018 at 17:42

1 Answer 1

0

I put also this setting and it solved :

custom_variable_classes = 'auto_explain'

1
  • Missing that line does produce output to the server log. You should figure out why you can't find the log output, as you will surely run into other problems in the future for which it would be helpful.
    – jjanes
    Mar 9, 2018 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.