Does anyone know how to configure it so that the Oracle wallet password can be authenticated with a web based Oracle application?

I’m trying to make secure LDAP connections with an Oracle web based application with secure ports. This requires that the application’s source code be able to authenticate against the Oracle wallet password. I am using ONLY the HTTP portion of Oracle Fusion 11.1 to serve these Oracle web pages. The wallet has been created and the certificates are in place and working.

When we used the Oracle 10g HTTP server we would just make an entry in the SSL.conf file; SSLWalletPassword encrypted or unencrypted Wallet password . But when I try it with Oracle Fusion 11.1, the HTTP server won’t start. I tried several versions of the above, but none worked. I also tried to solve the problem by modifying the opmn.xml file and changed the script to; But that didn’t work any either. When we try to authenticate with secure LDAP ports our web applications fail.

Does anyone have any ideas how to enable this with the HTTP portion of Oracle Fusion 11.1? Thanks.


Edited to add more information per here ~ Richard

I'm quite certain that I created the wallet correctly and that the certificate are correct. I've done it before, though not with Fusion 11.

I'm really starting to suspect there are network denial or port issues. I do a Utl_Http.Get_Detailed_Sqlerrm and will get an

ORA-24247: network access denied by access control list (ACL)... 


But the system guys say that all necessary ports are opened and access is okay. But I can make an entry in the DADs.conf file to "point" to another schema on another server (though 10G) and I have no "can't open wallet" issues.

1 Answer 1


ORA-24247 is something you would get after you already have a connection and are trying to use a network resource (such as UTL_HTTP). It sounds like you need to create an ACL (Access Control List). See http://oraclepoint.com/oralife/2010/10/08/configuring-wallet-manager-to-enable-https-connect-with-oracle-11g-database/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.