3

Is there a way in pgAdmin to organize Postgres databases into "folders" or groups? Each Django project I'm creating has it's own Postgres database, and I would like to find a way to organize them.

I asked this question on StackOverflow (https://stackoverflow.com/questions/22727629/organizing-postgres-databases), and my question was "put on hold" because it was off topic.

On StackOverflow, Erwin Brandstetter suggested I create a new Server Group and set the Group dialog box:

pgadmin server properties dialog box

My question is: how to create new options for the "Group" dropdown box? When I use pgAdmin3 command "Add Server" on my MacBook Pro, I only see one option under "Group" called "Servers".

Do I need to create a new "Database Cluster"? I found this command in the Postgres Documentation in Section 17.2:

$ initdb -D /usr/local/pgsql/data

On my MacBook Pro, my default databases are located at /usr/local/var/postgres/base and /usr/local/var/postgres/global.

Should I create a new directory, such as /usr/local/var/postgres2, and then execute a command like this?

$ initdb -D /usr/local/var/postgres2
  • 2
    Please add a link back to your previous question on this topic, so other people can find it later. You can do this by editing the question. Also, the groups in PgAdmin certainly have absolutely nothing to do with database clusters - I don't know what the answer is, but that isn't it. – Craig Ringer Mar 30 '14 at 1:36
  • You can edit the the input field of the "Groups" dropdown. Just enter a non-existing name in there to create a new group – a_horse_with_no_name Mar 30 '14 at 11:09
  • @CraigRinger Thanks for the tip on setting a new value for the group. Now I am able to create a new server group and add a new server using this new group. However, when I expand open the "Databases" icon in this new group, it contains all the databases in my original localhost database. Is this because I used the same default port (5432) in the "New Server Registration" dialog box? I tried changing the port to 5433, and I received this error message: "Server Doesn't Listen could not connect to server: Is the server running on host localhost and accepting connections on port 5433. – Stefan Musarra Mar 30 '14 at 19:32
5

Just type it into the "Group" field. Besides the listed options you can type a new group name freely.

It's a setting of pgAdmin, completely independent of the database itself and not stored in the database.

The handling is flexible, but renaming a bunch of "servers" can get tedious.

As to your comment: I repeat what I already wrote in my last answer:

Basically, each connection allows access to a whole database cluster

But if you follow my instructions over there, you connect to the right database automatically. I suggest, you read the manual about Managing Databases for basic understanding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.