I would like to install Oracle Instant Client on a Ubuntu 64 bit machine.

Following this link, I have installed the rpm packages basic, development and sqlplus using alien.


sqlplus  username/password@//dbhost:1521/SID
sqlplus: command not found

export ORACLE_HOME=/usr/lib/oracle/12.1/client64
bin  lib

sqlplus: command not found

I have tried the python script in this link, but this did not work. It conflicts with the installed 12.1 packages as it tries to install 11.2.


Easily solved:

export ORACLE_HOME=/usr/lib/oracle/12.1/client64

Stick those lines in your ~/.bash_profile if you want them to persist for a given user, or in /etc/bashrc to persist for all users.

|improve this answer|||||
  • Thanks Phil - it worked. Stuck it into ~/.bashrc. [/etc contained only bash.bashrc]. – Henk Jun 4 '14 at 13:14
  • +1 for helping users to use oracle db even on distributions which are considered "unsupported" by the company. – peterh - Reinstate Monica Jun 12 '14 at 13:27
  • @Peter -1 for appearing to have an attitude problem towards me – Philᵀᴹ Jun 12 '14 at 13:30
  • @Phil Is it possible for me to contact you privately? – peterh - Reinstate Monica Jun 12 '14 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.