1

When I'm pasting text in to my query window from Office the single quotes are being changed to a backtick. I have been through all the options in both Office and SQL but I can't find the/a setting to stop this happening. Is there such an option?

2
  • 3
    I'm voting to close this question as off-topic because this is a problem with smary quotes or similar in Office and not a DBA question. Feb 3 '15 at 13:01
  • I'm voting to close this question as off-topic because it has nothing to do with DBA work. Feb 3 '15 at 14:02
0

What I believe you're talking about is Microsoft Office changing single quotes to Smart Quotes.

It's an Autoformatting setting that you can change through the Options menu in Microsoft Word.

Go to Options -> Proofing -> Autocorrect Options

There are two places to change this:

  1. Under 'Autoformat', untick Replace -> Straight Quotes with Smart Quotes
  2. Under 'Autoformat as you type', untick Replace as you Type -> Straight Quotes with Smart Quotes

Alternatively, stop copying SQL from Microsoft Word.

https://www.simple-talk.com/blogs/2011/11/09/how-to-stop-office-2010-changing-and-to-smart-quotes/

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.