I installed Oracle 11g on my Windows Server 2008 workstation. After I try to configure oracle net server with port number 1521. But ONS error say to me as "Use another port number. This port is already in use.". How can I solve this problem?

enter image description here


Go to www.sysinternals.com - download the Sysinternals suite - and then run Tcpview and check what executable is running on port 1521. You can sort by port by clicking on the "Local port" column. If you try and run netstat -abn from the command line, you'll (in all likelihood) get an error "The requested operation requires an elevation". Just why this error occurs when this information is available through Tcpview is a mystery.

Do you have an Oracle instance already installed? I've installed Oracle on a number of Windows machines and I've never come across port 1521 being used by anything else. In any case, Tcpview will tell you which executable is blocking your Oracle port.

[EDIT - after further research]

I was reading around this and I came across this post, which shows that running resmon.exe will give you the information htat you want - Go to the "Listening Ports" tab, "Ports" column, but as pointed out, the GUI is truly awful.

From the same question here, from the command line you can run netstat -aon | find /i "listening"``, but as I mention, I can't get the corresponding process name using the b flag.

  • TNSLSNR.EXE is runing on 1521 and I have installed oracle instance, But now it deleted and clear all net service, now i want create from begin – Lilantha Lakmal May 11 '15 at 9:10
  • 1
    Uninstall everything to do with Oracle - it appears to me that there was some attempt made at a previous install. If you can, I would even reinstall Windows from scratch. But, at least make sure absolutely everything Oracle is uninstalled - and then reinstall from scratch. It's not normal for you to get the error message that you did. – Vérace May 11 '15 at 9:42
  • Thanx you for advice – Lilantha Lakmal May 11 '15 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.