1

I changed oracle instance to manually start from services.msc (service name is "OracleServiceORCL"), Because I want to start it up manually with SQL*Plus commands whenever I want, not with OS load.

Now I can't do that in SQL*Plus and I got this error:

ORA-12560: TNS:protocol adapter error

So I start it manually from services.msc and when database got ready I shut it down with SQL*Plus command. After that I realize that the service is still running, with very low consuming of resources.

I think this called "idle instance".

How can I automatically be in an idle instance state after I logged in to my Windows 8.1 to start oracle database whenever I want with SQL*Plus commands, not manually from services.msc?

3

You can configure this behaviour through the Administration Assistant, where you can choose to start (or not to start) the database instance with the Windows service.

Alternatively, you can do this with oradim, e.g:

oradim -edit -sid ORCL -startmode manual

The Windows service should be set to start automatically, and with the above setting, the database instance will not start with it.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.