1

"Hotfix 4422 for SQL Server 2016 (KB4013106)" installed for our installation of SQL Server 2016 over the weekend. Since then, all our backups are failing.

The backups are done via Maintenance Plans.

Anyone else experiencing the same issue?

Source: Backup DbNameHere (Logs) Description: The Execute method on the task returned error code 0x80131501 (Failed to connect to server (local).). The Execute method must succeed, and indicate the result using an "out" parameter. End Error Warning: 2017-04-17 08:50:01.12 Code: 0x80019002 Source: Daytime backups Description: SSIS Warning Code DTS_W_MAXIMUMERRORCOUNTREACHED. The Execution method succeeded, but the number of errors raised (2) reached the maximum allowed (1); resulting in failure. This occurs when the number of errors reaches the number specified in MaximumErrorCount. Change the MaximumErrorCount or fix the errors. End Warning Error: 2017-04-17 08:50:01.15 Code: 0xC0024104

  • Is there any additional information in the Sql Server error log during the time the backup job runs? Have you tried re-saving the maintenance plan to force it to regenerate the agent job? – Scott Hodgin Apr 17 '17 at 10:52
  • We've got Daytime, Nightly and Monthly subplans for backing up different databases on different schedules. Oddly, the nightly plan worked just fine this evening... whereas the daytime subplan is still failing, even having edited and re-saved the subplan as @Scott-Hodgin suggested. – Matty Brown Apr 17 '17 at 19:59
2

Edit the maintenance plan and change the credentials used for Local server connection to Use Windows NT Integrated Security.

  1. Open the Maintenance Plan in Design view.
  2. Click Manage Connections
  3. Select Local server connection and click Edit
  4. Under Enter information to log on to the server, choose Use Windows NT Integrated security
  5. Save your changes
  6. Execute the plan/schedule to verify that this has cured the problem

No idea what causes this issue, but for us, it seems to have been directly after Hotfix 4422 for SQL Server 2016 (KB4013106) was installed automatically by Windows Update.

  • Bummer. Unfortunately, this fix does not solve my issue I just get a message saying "Failed to connect to server ..." when choosing Integrated Security. Not sure why since I allow it at the server level... – Jim Oct 4 '17 at 14:11
0

I had to have same issue on my SQL Server 2016. When I check SQL Server ErrorLog. I saw that my service user cannot connect to one of the database.

Login failed for user ''. Reason: Failed to open the explicitly specified database 'TEST2'. [CLIENT: <local machine>]  
Error: 18456, Severity: 14, State: 38.

When I check this database it's state was recovering. When I delete this database (It was not important for me), the problem has been fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.