0

I have attempted to install Oracle 12.1.0.2.0 on Oracle Linux 6.7 multiple times without success. I have installed the database software only with the configuration assistant and am attempting to configure the listener with the net configuration assistant (netca). I go through the steps and the netca hangs and eventually fails on the standard port saying it is in use by another process. I have checked the ports (sudo ss -tulw) and know this is not true. I have searched and have seen similar problems that seem to be associated with either the .bash_profile or /etc/hosts files not being set correctly. I have checked both of those files and do not see any issue, but I am new to setting up a DB so please see below for any possible errors:

/etc/hosts

#127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

127.0.0.1 localhost.localdomain localhost.localdomain localhost
192.168.1.77 ggsrv1.localdomain ggsrv1
192.168.1.78 ggsrv2.localdomain ggsrv2

I am attempting to set up 2 databases to try out Oracle GoldenGate. so ggsrv1 is the current database I am trying to install and ggsrv2 is the other database I hope to install, an a second vm.

.bash_profile

PATH=$PATH:$HOME/bin

export PATH

export TMP=/tmp
export TMPDIR=$TMP
export ORACLE_HOSTNAME=ggsrv1.localdomain
export ORACLE_UNQNAME=db1
export ORACLE_BASE=/u01/app/oracle
export ORACLE_HOME=$ORACLE_BASE/product/12.1.0.2/db_1
export ORACLE_SID=db1
export PATH=/usr/sbin:$PATH
export PATH=$ORACLE_HOME/bin:$PATH
export LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib
export CLASSPATH=$ORACLE_HOME/jlib:$ORACLE_HOME/rdbms/jlib

I am able to start up dbca and netca from the terminal so I feel the paths are set correctly. Is there something above that I am not seeing or could there be another possible issue?

lsnrctl start output

LSNRCTL for Linux: Version 12.1.0.2.0 - Production on 04-SEP-2019 07:44:18

Copyright (c) 1991, 2014, Oracle.  All rights reserved.

Starting /u01/app/oracle/product/12.1.0.2/db_1/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 12.1.0.2.0 - Production
Log messages written to /u01/app/oracle/diag/tnslsnr/ggsrv1/listener/alert/log.xml
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=ggsrv1.localdomain)(PORT=1521)))

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
TNS-12535: TNS:operation timed out
 TNS-12560: TNS:protocol adapter error
  TNS-00505: Operation timed out

the contents of /u01/app/oracle/diag/tnslsnr/ggsrv1/listener/alert/log.xml show that it is listening on the post in /etc/hosts.

Any help is greatly appreciated. Thank you

Edit

I did not have a listener.ora file so I created one that looked like the below.

LISTENER=
  (DESCRIPTION=
    (ADDRESS_LIST=
      (ADDRESS=(PROTOCOL=tcp)(HOST=ggsrv1.localdomain)(PORT=1521))
      ))

 SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = db1)
      (ORACLE_HOME = /u01/app/oracle/product/12.1.0.2/db_1)
    )
)

I then ran the below with the following output:

[oracle@ggsrv1 admin]$ lsnrctl start LISTENER

LSNRCTL for Linux: Version 12.1.0.2.0 - Production on 05-SEP-2019 10:24:18

Copyright (c) 1991, 2014, Oracle.  All rights reserved.

Starting /u01/app/oracle/product/12.1.0.2/db_1/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 12.1.0.2.0 - Production
System parameter file is /u01/app/oracle/product/12.1.0.2/db_1/network/admin/listener.ora
Log messages written to /u01/app/oracle/diag/tnslsnr/ggsrv1/listener/alert/log.xml
TNS-01150: The address of the specified listener name is incorrect

Listener failed to start. See the error message(s) above...

I do not have a sqlnet.ora file, and do not know what it is, but I will investigate now.

Edit 2

After reading about the files located in $ORACLE_HOME/network/admin it seems like I do not need these if I accept the system defaults correct?

I have added a listener.ora and tnsnames.ora files anyways, but I still cannot start the listener:

TNS-01150: The address of the specified listener name is incorrect

the contents of my tnsnames.ora file:

db1 = (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = ggsrv1.localdomain)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = db1)
    )
  )

ifconfig output

  eth0      Link encap:Ethernet  HWaddr 08:00:27:D0:AE:EC  
          inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fed0:aeec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:44741 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32187 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:30928622 (29.4 MiB)  TX bytes:5468976 (5.2 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:480 (480.0 b)  TX bytes:480 (480.0 b)
  • Forget netca. lsnrctl start. If it works, it is done. If it does not, at least it displays the address it is trying to use. – Balazs Papp Sep 4 '19 at 14:34
  • When you say you’re trying to set up 2 databases what do you mean? 2 different hosts with a database on each, or 1 host (with 2 IP addresses and names) with 2 databases on? – Philᵀᴹ Sep 4 '19 at 14:48
  • @BalazsPapp I added the the output from lsnrctl start above. – Jeff Tilton Sep 4 '19 at 14:52
  • @Philᵀᴹ I am trying to set up 2 different hosts with a database on each. I have 2 different vm's set up with virtualbox. – Jeff Tilton Sep 4 '19 at 14:53
  • @JeffTilton are you able to ping 192.168.1.77 ggsrv1.localdomain ggsrv1 192.168.1.78 ggsrv2.localdomain ggsrv2 both as IP and name? – VCarstein Sep 5 '19 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.