0

As our (32-bit) application uses the Oracle client for communication with the Oracle server I have set up a test environment on a Microsoft Windows Server 2019 Datacenter. I have installed the Oracle DB 19c (19.3.0.0 64-bit) and the appropriate Oracle client (19.3.0.0 32-bit).

As soon as I start TNSPING or SQLPLUS out of the installation directory of the Oracle client, the Windows error message "The application was unable to start correctly (0xc000007b). Click OK to close the application." occurs.

I have searched the internet for remedy and tried all the 'restart Windows' and 'reinstall framework' hints without success. The hint "64-bit software on 32-bit Windows doesn't work." simply doesn't apply to my problem.

Is there anybody out there who has further ideas - perhaps ideas more close to the Oracle world.

Thanks in advance, Ben

1
  • That really sounds like an OS error. What happens if you try 64bit oracle client? – Michael Kutz Sep 3 '20 at 14:07
1

I had exactly the same errors after installing a 32-Bit client (19.9.0.0.201020). Windows application event log stated an error concerning "C:\Windows\system32\ntdll.dll". This is a 64-Bit DLL with the 32-Bit counterpart in "C:\Windows\SysWow64".

This is the solution

You need to add C:\Windows\SysWow64 to the PATH environment variable. This can be done temporarily using:

SET PATH=%PATH%;C:\Windows\SysWow64 

Furthermore you need to have 32-Bit Microsoft Visual C++ Runtime 2015-2019 installed. The latest Visual C++ Redistributable can be downloaded from:

Hope this helps.

0

we got the exact same error on a servercluster with a similar environment since last week! I already did some investigation together with the server provider. This is what we got so far:

Environment Windows Server 2016 with Oracle Client 12.1.0.2.0 (combined 32 and 64 Bit Client) Oracle Path: C:\Windows\Oracle\DAIOraClx32 and C:\Windows\Oracle\DAIOraClx64

Error Analysis

  1. Running TNSPING , SQLPLUS from OraCl32-Bin from cmd OR doubleclick gives back "0xc000007b"-Error, as well as nearly every other exe in DAIOraClx32 Exception: zip.exe and unzip.exe both run fine Also: I copied nslookup.exe (as a text-exe with can be started solitary) to the bin-dir, also opend without error.

  2. Running TNSPING , SQLPLUS from OraCl64-Bin: No error!

  3. Copied TNSPING from OraCl32-Bin to another directory: still got the same error

Action History I checked with datacenter what happened last days. The only change was an automatic update-routine for replacing McAffe virusscan with WindowsDefender: After that, we got the error. Could be verified by loading server backup from before, when the oracle-client worked fine.

We tried to reproduce the update-routine, but had to do it manually - this time, we could not reproduce the error. Still working on it.

Suggestion What is peculliar to me: The problem seems not be related on Oracle Version, rather than combination of Virusscanner-Update + Oracle32bit-Client.

Question Did you also have McAffee/WindowsDefener and some update activities for one or both of them?

Kind regards, also Ben ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.