0

How to determine what is causing Microsoft SQL Server to create dump files over and over taking up 170 GB of disk space? How do I troubleshoot what is causing the dumps?

The path of the dump files is

C:\Program Files\Microsoft SQL Server\MSSQL15.MSSQLSERVER\MSQL\Log\Polybase\dump

Can I delete these?

I have looked at The SQL server Log folder is expanding because of the SQL Dump files (what to do with it ?) but it doesn't really answer my question - it mainly states to contact Microsoft.

1
  • What are the file extensions of the files there? Did you open any of them and see what they contain? – Aaron Bertrand Sep 30 '20 at 1:00
1

You can check the SQL Server Error Log to get more information as to why dump files were generated. Microsoft also provides the sys.dm_server_memory_dumps dmv for troubleshooting, but it isn't clear to me how that dmv would be helpful.

1

Since these dumps are being created specifically in the polybase subdirectory, you may want to focus specifically on polybase dumps.

At this link, Niels Berglund shows how TCP protocol being disabled for SQL Server connectivity lead to multitudinous polybase dumps being created. https://nielsberglund.com/2019/11/20/fix-polybase-in-sql-server-2019-developers-edition/

0

In my case there were 2 instances of sql... MSSQLSERVER and MSSQLSERVER2. Looking at services, I found a SQL Polybase (MSSQLSERVER2) which was the one that generated the files that were filling the hard drive, in a brutal way. So leave them as a stopped service and in manual type, then stop all MSSQLSERVER2 services, and leave them as manual. Delete the dmp files from the dump folder, and until today the files do not appear .dmp. It was my solution to this problem!

What I did prior to that process is to pass all databases to the MSSQLSERVER instance. and everything keeps working perfectly.

Maybe you have to do the same.

2
  • ola aqui tines escribir en ingles – nbk Apr 18 at 22:04
  • The issue was similar in that a copy of sql running and was creating error files and dumping them to the hard disk. Thanks for follow up. – Tanooki Mario May 20 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.