1

I'm trying to simplify deployment of SSIS package to a remote server. At the moment, I have

  • Local Visual Studio SSDT and SSIS package that has 4 connection managers - DEV environment
  • Remote server with SQL, SSMS, and SSDT installed - PROD environment

The easiest way to deploy SSIS package from local computer to the remote server is to

  • Create SSIDB catalog on the remote server
  • Perform Deploy from Visual Studio and point it to the catalog created on the remote server

In this case everything works fine.

In the meantime, some remote servers may not be accessible from Visual Studio directly, so I'm trying to precompile SSIS package on local computer, upload to the remote server and add it to SQL server job as a single file, like it's described in this article. The second screenshot in that article shows that I can choose Package Source = File System and specify a path to SSIS package file.

The issue

When I deploy SSIS package from Visual Studio to SSIDB catalog and create SQL server job using package in the catalog, it correctly shows 4 connection managers used by the package. When I create SQL server with manually uploaded SSIS package file, the tab Data Sources in SSMS shows empty list of connection managers. Why in the second scenario, connection managers were not deployed with the package?

0

If VS doesn't have access to the remote server, you can build SSIS package, upload it to the remote server and install using SSMS.

  • Build SSIS project to create IPSAC file in BIN folder
  • Copy IPSAC file to the remote server
  • Go to the remote server => SSMS => Integration Services Catalog => create new folder
  • Created folder will have 2 sub-folders, one of them is Projects
  • Click right mouse button on the Projects folder and choose option Deploy
  • In the popup window, choose to deploy project and point it to IPSAC file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.