I took the DS210 course offered by Datastax and prepared a cluster of almost the same configuration by myself. I edited the /etc/dse/cassandra/cassandra-env.sh file in Exercise 2.3, but I still got "Failed to connect over JMX; not collecting these statscassandra-stress" error message; I get "not collecting these stats" and cassandra-stress does not work properly. When I look at the jconsole, the graph is working, so it seems to be collecting information. What should I change? I am running on DSE 6.8.

cassandra-stress cassandra-stress user profile=/home/cassandra01/ubuntu/stress/TestProfileEdited.yaml ops(insert=1,user_by_email=1) -node -port jmx="7199"

  Type: user
  Count: -1
  No Warmup: false
  Consistency Level: LOCAL_ONE
  Target Uncertainty: 0.020
  Minimum Uncertainty Measurements: 30
  Maximum Uncertainty Measurements: 200
  Command Ratios: {insert=1.0, user_by_email=1.0}
  Command Clustering Distribution: clustering=gaussian(1..10)
  Profile File(s): /home/cassandra03/ubuntu/stress/TestProfileEdited.yaml
  Auto: true
  Min Threads: 4
  Max Threads: 1000
  Distribution: Gaussian:  min=1,max=1000000,mean=500000.500000,stdev=166666.500000
  Wrap: false
  Revisits: Uniform:  min=1,max=1000000
  Visits: Fixed:  key=1
  Row Population Ratio: Ratio: divisor=1.000000;delegate=Fixed:  key=1
  Batch Type: not batching
  Ignore: false
  Tries: 10
  No Summary: false
  No Settings: false
  No Progress: false
  Show Queries: false
  Query Log File: null
  File: null
  Interval Millis: 1000
  Level: NORMAL
  Connection Style: CQL_PREPARED
  CQL Version: CQL3
  Protocol Version: DSE_V2
  Username: null
  Password: null
  Auth Provide Class: null
  Max Pending Per Connection: 128
  Connections Per Host: 8
  Compression: NONE
  Nodes: []
  Is White List: false
  Datacenter: null
  Keyspace: null
  Replication Strategy: org.apache.cassandra.locator.SimpleStrategy
  Replication Strategy Options: {replication_factor=1}
  Table Compression: null
  Table Compaction Strategy: null
  Table Compaction Strategy Options: {}
  truststore=null; truststore-type=null; truststore-password=null; keystore=null; keystore-type=null; keystore-password=null; ssl-protocol=TLS; ssl-alg=SunX509; ssl-ciphers=TLS_RSA_WITH_AES_128_CBC_SHA,TLS_RSA_WITH_AES_256_CBC_SHA; 
  Native Port: 9042
  JMX Port: 7199
Send To Daemon:
  *not set*
  File: null
  Revision: unknown
  Title: null
  Operation: USER
  Wrap: true
  Split Factor: 1

******************** Profile(s) ********************
  Keyspace Name: dse_stress
  Keyspace CQL: 
CREATE KEYSPACE dse_stress WITH replication = {'class': 'SimpleStrategy', 'replication_factor': '1'};

  Table Name: user_by_email
  Table CQL: 
CREATE TABLE user_by_email (
  email TEXT,
  password TEXT,
  user_id UUID,
  PRIMARY KEY ((email))

  Extra Schema Definitions: null
  Generator Configs:
    password: Size: Exponential:  min=8,max=30,mean=14.234680;Identity: Uniform:  min=1,max=1000000;
    email: Size: Gaussian:  min=8,max=30,mean=19.000000,stdev=3.666667;Identity: Exponential:  min=1,max=1000000,mean=144764.693015;
    user_id: Size: Fixed:  key=4;Identity: Uniform:  min=1,max=1000000;
  Query Definitions:
    get_user: CQL:select * from user_by_email where email = ?;Fields:samerow;
  Token Range Queries:
  Insert Settings:
    partitions: fixed(1)
    batchtype: UNLOGGED
    select: fixed(1)/1
Connected to cluster: Test Cluster, max pending requests per connection 128, max connections per host 8
Datacenter: dc1; Host: /192.168.xx.xxx; Rack: rack1
Datacenter: dc1; Host: /192.168.xx.xxx; Rack: rack1
Datacenter: dc2; Host: /192.168.xx.xxx; Rack: rack1
Created schema. Sleeping 1s for propagation.
Insert Statement:
  UPDATE user_by_email SET password = ?,user_id = ? WHERE email = ?
Generating batches with [1..1] partitions and [1..100] rows (of [1..1] total rows in the partitions)

Sleeping 2s...
Warming up insert with 0 iterations...
Failed to connect over JMX; not collecting these stats

1 Answer 1


Check your cassandra-env.sh file. Remote JMX needs to be enabled for that to work.

Look for the LOCAL_JMX variable, and make sure that’s getting set to something other than ”yes.”

Once that’s done, cassandra-stress should be able to pull metrics w/JMX.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.