0

I'm trying to install Oracle Forms and Reports on a new server 64 bit (Ubuntu Trusty Tahr). (I'm only actually interested in the report server component).

I can't find a version that I can install on oracle.com - the only versions I can find require Oracle Fusion Middleware which we are not licensed for. (I have actually tried to install this but I can't get to work - didn't follow this up too far due to the licensing issues)

My fallback plan is to install the 11g 32 bit version in a 32 bit chroot on the server, but am hoping to avoid this.

Does any one know if it's possible to get the reports server running without Middleware? (Or any ideas on which download from Oracle.com would be a likely candidate).

Thanks

edit: just to clarify - the answer given by Vérace didn't answer the question (the versions suggested still required Middleware to be installed). I'm still wanting to determine if it is possible to run a 64bit version of Reports Server without Middleware already being installed

1

This couldn't have been easier

Forms and Reports here (Fusion Middleware) and alternative (non-Fusion) here. You may need an app server - not sure.

This was a relatively easy Google - that normally merits a -1, but since it's your first post here, I'll let it slide. Do they not have similar rules about question research on StackOverflow (where you have a rep. of nearly 1.5k)?

  • Yup. I've been googling for days with no luck. I have previously downloaded both of those versions suggested already (and seems like a 100 more) with no success. Just tried to fire those specific installers up again to see the problem I had with them.... and found the non-fusion one doesn't extract... so must have somehow missed running that one. Redownloading now - will let you know if it works. – Dave Smylie May 19 '15 at 23:15
  • 1
    If you've already done this, then I would recommend trying with a clean VM before putting this anywhere important. At least if it works for the VM, you know it has to work on your dev/prod/whatever system. – Vérace May 19 '15 at 23:19
  • Have tried both of them (but more relevantly- the non-Fusion version) and it's prompting me for the Oracle Middleware Home and giving a warning that 'An Application Server must already be installed'. Perhaps the issue is that I'm getting Oracle Middleware and Oracle Fusion Middleware confused - I thought they were the same thing? – Dave Smylie May 20 '15 at 3:57
  • I'm afraid I don't know - I've Googled "difference between oracle fusion and oracle middleware" and "between oracle middleware and oracle fusion middleware". There's lots of links - my primary recommendation now is to go to "forums.oracle.com" and see if you can find a Forms/Reports group. I used to know my way round the site very well, but they've changed it (and not for the better). It's been a while since I've used Oracle so I'm not as up to date as I could be. This wiki might be a good place to look. – Vérace May 20 '15 at 4:25
  • Here and here look like good places to start. This looks like the best site. – Vérace May 20 '15 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.