0

Question edited for clarity.

Goal: install Oracle 19c on windows 10 and make a PDB.

Background: I installed Oracle on 2 computers incorrectly (unzipped the oracle 19c file into C:\App\db_home1, instad of into C:\App\oracle\product\19.3\db_home1). I tried fixing this by uninstalling (manually by following these instructions: https://www.youtube.com/watch?v=EHFbk_6ThAQ ). Now i'm trying to re-install.


Problem reinstalling on computer 1:

When i run setup.exe I get an error on the installation step that says [INS-20802] Oracle Database Configuration Assistant Failed.

When I open "installActions2020-09-05_03-48-30PM" I get this error at the bottom: INFO: [Sep 5, 2020 4:38:02 PM] [FATAL] Error while executing "C:\App\oracle\product\19.3\db_home1\rdbms\admin\dbmssml.sql". Refer to "C:\App\oracle\cfgtoollogs\dbca\orclglobal\dbmssml0.log" for more details. Error in Process: C:\App\oracle\product\19.3\db_home1\perl\bin\perl.exe

When i go to C:\App\oracle\cfgtoollogs\dbca\orclglobal\dbmssml0.log, it's blank.

Trying Joe's suggestions:

C:\>echo %ORACLE_HOME%
%ORACLE_HOME%

C:\>where sqlplus
'where' is not recognized as an internal or external command,
operable program or batch file.

C:\>C:\App\oracle\product\19.db_home/deinstall/deinstall
The system cannot find the path specified.

C:\>

^ but i have sql plus ^ I never had an env variable named oracle_home. this returns the env variable for the current oracle installation (that isn't complete)

C:\>echo %path%
C:\App\oracle\product\19.3\db_home\bin;C:\Program Files (x86)\Applied Biosystems\QuantStudio Design
'Analysis' is not recognized as an internal or external command,
operable program or batch file.

I think the new installation that i'm trying to install is the only thing the installer is picking up. But I don't know what to do with this message. Where do i run this?

enter image description here


Update: I can connect to the CDB i create, but there's no PDB$SEED. enter image description here

But I have a seed directory C:\App\oracle\oradata\ORCL\pdbseed

enter image description here

enter image description here

enter image description here


Problem reinstalling on computer 2:

INS-30014: Unable to check whether the location specified is on CFS

Here's what Oracle has to say about this error:

Cause: The location specified might not have the required permissions.

Action: Provide a location which has the appropriate required permissions.

All the users (me, admin, all possible users) have full permissions on the D drive.

Another solution I found to INS-30014 is to disable the network adapter. I tried that and it still didn't work. (My ethernet was already disabled, so i disabled the internet and that didn't change anything).

7
  • Did you look at the log as advised in the error message ? What does the log say ? Sep 6, 2020 at 5:53
  • Oh and following random instructions you find on the internet rather than simply following those in the manual is a recipe for failure. Sep 6, 2020 at 5:55
  • @AlbertGodfrind it says Refer to "C:\App\oracle\cfgtoollogs\dbca\orclglobal\dbmssml0.log" for more details. When i go to that file, it's blank. The documentation was confusing, so i wanted to see how other people to do it. But i guess that wasn't a good idea. Sep 6, 2020 at 12:45
  • You don't enough memory(RAM) on second computer not disk space(800G is disk space). How much memory are you allocating for database?.Try to adjust memory slider to 2G(that's minimum for 19c)
    – Joe
    Sep 6, 2020 at 14:53
  • @Joe yep, thank you, you're right. once i closed my one million tabs i got the space error to go away. now i just have the INS-30014. Sep 6, 2020 at 14:59

2 Answers 2

3

Never delete manually on Windows instead use deinstall.batfrom elevated command prompt from root drive C:\%ORACLE_HOME%\deinstall\deinstall.bat (don't initiate deinstall.bat from inside oracle home)

Remove ORACLE_HOME variable from system/user and ORACLE_HOME/bin from path .

If you removed previous installation and trying to install new database not sure why are you starting with DBCA instead of setup.exe.You mentioned you're trying to install PDB implies you already installed CDB i.e ORCLGLOBAL or am I missing something

Edit:-Deleting registry entries,oracle inventory,services and oracle home directory manually is dirty uninstall if not careful can lead to unintended consequences(current error might be or may not related to previous dirty uninstallation). Oracle provides clean uninstall tools in oracle home directory deinstall.bator gui setup.exe(OUI directory) in oracle home directory (you can check in unzipped folder for directories deinstall and 'oui`).

DBCA should be used only after post install to add new instance/database,new pluggable database or after installing software only.

Since you dirty uninstalled double click setup.exe in oracle home directory (check the image below).

enter image description here

Uninstall tools are shown in red rectangles boxes

Edit:-

On computer one you have conflict in environment from previous installation or leftovers .Verify from command prompt echo %ORACLE_HOME% and where sqlplus if either of the command returns remove those variables alternatively easy way is go to OUI folder as depicted in above picture and next go to bin directory and double click setup.Select all remove everything and go to environment tab select remove everything and start setup again.(I'm assuming you don't have any other Oracle product installations)

enter image description here

enter image description here

enter image description here

10
  • The documentation says to do %ORACLE_HOME%\deinstall. Is that not an example of initiating deinstall from the oracle home? Also it says the deinstall tool is available here oracle.com/database/technologies/… but i don't see it. Every step of the instructions I've read on the documentation just sounds like a day long mystery to solve, instead of a helpful piece of information. Sep 6, 2020 at 13:03
  • I figured out how to make a chat room! chat.stackexchange.com/rooms/112711/… Sep 6, 2020 at 13:23
  • I don't understand what you mean by "don't initiate deinstall.bat from inside oracle home". Also, now that i deleted the original oracle home directory, is using deinstall.bat applicable for fixing whatever i did wrong? I've removed ORACLE_HOME from env variables. Why DBCA instead of setup.exe? I tried to do setup.exe first, and that's when I ran into Oracle Database Configuration Assistant Failed. I searched for an answer and someone on SO their solution was to skip that step, have the setup wizard create a CDB (orclglobal in my case) and then use DBCA to make a PDB. Sep 6, 2020 at 14:15
  • Your images are super noob-friendly, thank you! Yes, clicking setup.exe is exactly what I did. I'm trying to run that as administrator. Sep 6, 2020 at 14:53
  • Thank you for such detailed explanations. I just tried doing what you suggested with the new edits. I don't think the echo or where commands work. Also, when I say remove it says "run command C:\App\oracle\product\19.db_home/deinstall/deinstall to deinstall oracle." What does that mean? Run where? It doesn't work in command prompt. That little pop up window is the only option that it gives me. I'll add what I see to my quesiton. Sep 7, 2020 at 1:34
0

For Complete Oracle 19c uninstallation, you need to

  1. remove registers enter image description here
  2. remove the users created during Oracle installation
  3. remove path environment

Delete Oracle folder from windows, and restart. Now you can re-install Oracle.

The trickiest part here is to remove the registers. For details read Uninstall Oracle 19c:

I have followed this tutorial.

Basically Oracle installation does : Create register, Path environment, and create Database User and Groups. You need to remove them manually, as Oracle did not provided Uninstaller.

Information Source: https://www.swapreference.com/oracle/19c/uninstall-oracle-19c-win-10/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.