1

I'm using Microsoft Access 2016 32bit on Windows 10. My issue is the Field Size property list is empty for the Number data type. Why is this empty? How can I change a number's field size? I am trying to specify the Byte field size for my field.

Even when starting from scratch and creating a new empty database, with new tables, I am unable to select a field size for the number data type.

With my existing databases I am unable to change field size of existing number type fields. For example, existing byte fields are still bytes however if I open the design view on the table and click the field size drop down list for that field the list is empty.

I expected a number field's field size drop down list to contain byte, integer, single, double, etc. however it is empty. This list was previously available to me.

Is there a MS Access setting that I need to change? Or is this a bug?

My computer recently had a windows update, it's unclear to me whether or not this included an office update.

UPDATE As a workaround I can execute ALTER TABLE sql commands to modify my field's data types. examples

0

There is a bug in Access 2016. The MS Access team is aware of it, and is working on a fix for it. No ETA yet on when it will be available.

It involves the Datatype dropdown for Numbers.

Only the default datatype is available.

If you need to change or add number fields, the work around is to go to Options for Object Designers and change the Default Datatype for numbers to the one you need. It then becomes available in the dropdown in place of Long Integer.

There have been some reports that Wizards may also be broken. That, however, hasn't been widely confirmed.

1

As of 7/27/16 I ran an update for Office and the issue appears resolved. To run the update in MS Office 2016 go to any MS Office application and go to File -> Account -> Update Options -> Update Now.

0

Thanks for the info! fred & WGLJ. The option of using SQL to make the change works - add the sql commands to a new query's sql view and run. There is no feedback of what happened, but when you open the table, you'll see.

  • I don't think that this is an answer. I know (God knows why!) you can't comment until you have a rep of 50, so could you flag this for a moderator's attention to change it to one? – Vérace Jun 30 '16 at 2:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.