2

I'm currently working on a cluster with DataStax Enterprise 6.8, but the address part of the picture is showing up as localhost (127.0.0.1).

How can I get it to show the actual IPv4 address?

Current Status

1 Answer 1

2

It sounds like you have left the default configuration which means that the DSE process defaults to listening for requests on localhost in cassandra.yaml.

The listen_address is used for private node-to-node (internode) communication so on multi-NIC servers, this is set to the node's IP address.

Clients (applications) connect to DSE nodes on the native_transport_address so this is set to a public IP address that clients can reach.

In cassandra.yaml, set:

listen_address: private_ip
native_transport_address: public_ip

For servers which only have one network card, you can set both properties to the same IP address. Cheers!

2
  • I have DSE6.8 on each of my 3 machines using Virtual box, and I had PriateIP in all those 2 settings in cassandra.yaml, so I will try it. Thanks.
    – Youjie
    Aug 28, 2022 at 12:17
  • Hi Erick One unit started up fine, but when I brought up the second unit it did not connect properly, I got an error saying Connect Refused. Anything else I should be aware of? The seed node has a private IP of node1. It is a virtualbox so the public IP is common.
    – Youjie
    Aug 29, 2022 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.