My node worked normally, and I could use nodetool status normally, but when I changed endpoint_snitch to Ec2Snitch I started getting the error:

nodetool: Failed to connect to '' - ConnectException: 'Connection refused'.

Although it worked fine when endpoint_snitch was SimpleSnitch

The node private address is and attached to security group that has 7199 open for inbound and outbound for the range that covers

So, any idea?

1 Answer 1


Ec2Snitch is specifically designed for Cassandra being installed in AWS EC2 instances. Please confirm if your installation is in AWS? In case you are, check whether listen address in cassandra.yaml is set to the private ip of the node (instead of localhost)

SimpleSnitch should work fine for Single datacenter. Its recommended to use GossipingPropertyFileSnitch for production.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.