1

I need assistance getting labels to print from SSRS 2014 to a Zebra GK420D direct thermal label printer. The labels show up when running the report but when I print them to the label printer, all that comes out is a blank page. If I export to a PDF and then print, it works fine, but this isn't a viable option for our end users.

I've set the printer to the correct label size as well as changing the page size in the report to match and I've changed the printer settings to "Always use driver settings" and to print directly to the printer (bypassing the spooler) which were the two recommendations I found thanks to googling. Any assistance is greatly appreciated.

  • Gray area if this is on topic, you may get pushed off to to superuser. Sounds like a problem with printer drivers – Evan Carroll Aug 23 '18 at 19:46
  • Apologies for possibly being off topic. Thanks for the heads-up, – JonDBA5420 Aug 23 '18 at 19:48
  • I don't know if this is an option, but in SSRS 2016 the printing engine has been changed - it now always renders to PDF first, and then sends that to the printer. Which generally makes things rather more consistent. – Jerb Aug 24 '18 at 8:28
0

The issue appears to have been limited to printing from report builder. When I print from SSRS directly, the labels print out as intended. Not sure what the problem is with Report Builder but I'm content the problem has been fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.